summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vpp-core/vpp-core.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/vpp-core/vpp-core.bb')
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
new file mode 100644
index 00000000..173d2df5
--- /dev/null
+++ b/recipes-extended/vpp-core/vpp-core.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Vector Packet Processing"
2
3S = "${WORKDIR}/git"
4PV = "18.01"
5
6LICENSE = "Apache-2.0"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
9
10AUTOTOOLS_SCRIPT_PATH = "${S}/src"
11
12SRCREV = "d3111f07682585079069b91666afffbc73c79cd8"
13
14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/vpp;nobranch=1 \
15 file://0001-Link-vpp-api-with-shared-libs-if-static-is-disabled.patch \
16 file://0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch \
17 file://config.h \
18 "
19DEPENDS = "dpdk openssl numactl bison-native vpp-core-native"
20DEPENDS_class-native = "bison-native openssl-native"
21
22inherit autotools
23inherit pkgconfig
24inherit python-dir
25
26export ARCH="arm64"
27
28EXTRA_OECONF = " \
29 --disable-dependency-tracking \
30 --with-libtool-sysroot=${SYSROOT} \
31 --srcdir=${S}/src \
32 --enable-perftool \
33 --disable-papi \
34 --disable-japi \
35 --disable-static \
36 --with-pre-data=128 \
37 --disable-flowprobe-plugin --disable-ixge-plugin \
38 --disable-memif-plugin --disable-sixrd-plugin --disable-gtpu-plugin \
39 --disable-ioam-plugin --disable-lb-plugin --disable-ila-plugin \
40 --disable-nat-plugin --disable-l2e-plugin --disable-stn-plugin \
41 --disable-pppoe-plugin --disable-kubeproxy-plugin \
42 --disable-vom --disable-dpdk-plugin \
43"
44
45EXTRA_OECONF_append_class-native = " --disable-vlib"
46
47
48include vpp-pkgs.inc
49
50
51do_configure_append () {
52 ( cd ${B} && mkdir -p vppinfra vpp/app )
53 cp ${WORKDIR}/config.h ${S}/src/vlib/config.h
54}
55
56do_install_append() {
57 mkdir -p ${D}/etc/vpp
58 cp ${S}/src/vpp/conf/startup.conf ${D}/etc/vpp/startup.conf
59}
60
61
62BBCLASSEXTEND = "native nativesdk"