summaryrefslogtreecommitdiffstats
path: root/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb')
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb
new file mode 100644
index 00000000..f04e1e9f
--- /dev/null
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_21.05.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "PKTGEN DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0245ceedaef59ae0129500b0ce1e8a45"
4
5DEPENDS += "libpcap dpdk lua lua-native"
6
7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=https;nobranch=1 \
8 file://fix-gcc11-mismatched-dealloc-error.patch \
9"
10SRCREV = "3a09aa916597fb9a97ee8eec50044cbdb9c4abde"
11
12S = "${WORKDIR}/git"
13
14DPAA_VER ?= "dpaa"
15export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
16export RTE_SDK = "${RECIPE_SYSROOT}/usr/share/dpdk"
17
18inherit meson pkgconfig
19
20MESON_BUILDTYPE = "release"
21EXTRA_OEMESON += '-Dc_args="-DRTE_FORCE_INTRINSICS"'
22
23do_configure:prepend() {
24 sed -i "/^add_project_arguments('-march=native'/s/^/#&/" ${S}/meson.build
25}
26
27do_install() {
28 install -d ${D}${bindir}/
29 install -m 0755 app/pktgen ${D}${bindir}/
30 install -m 0644 ${S}/Pktgen.lua ${D}${bindir}/
31}
32
33INSANE_SKIP:${PN} = "ldflags"
34INHIBIT_PACKAGE_STRIP = "1"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36PARALLEL_MAKE = ""
37COMPATIBLE_MACHINE = "(qoriq-arm64)"