summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb')
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
new file mode 100644
index 00000000..fb41b457
--- /dev/null
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python3-six-native coreutils-native autoconf-native automake-native"
6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7
8inherit python3native pkgconfig
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
11SRCREV = "f2c0744d2f68c4cd2840d6e409d7b0520e4caf99"
12
13S = "${WORKDIR}/git"
14
15do_configure() {
16 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
17 ${S}/boot.sh
18 ${S}/configure --host aarch64-fsl-linux --with-dpdk=static --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
19}
20
21do_install:append() {
22 install -d ${D}${bindir}/ovs-dpdk
23 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
24 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
25 cp -rf ${S}/ovsdb/ovsdb-client ${D}${bindir}/ovs-dpdk
26 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
27 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
28 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
29 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
30 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
31}
32
33ALLOW_EMPTY:${PN} = "1"
34INHIBIT_PACKAGE_STRIP = "1"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(qoriq-arm64)"