summaryrefslogtreecommitdiffstats
path: root/recipes-extended/odp/odp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/odp/odp_git.bb')
-rw-r--r--recipes-extended/odp/odp_git.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
new file mode 100644
index 00000000..32e31072
--- /dev/null
+++ b/recipes-extended/odp/odp_git.bb
@@ -0,0 +1,63 @@
1require odp.inc
2
3inherit autotools-brokensep
4
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7DEPENDS = "openssl cunit libxml2"
8
9RDEPENDS_${PN} = "bash libcrypto libssl odp-module odp-counters"
10
11ODP_SOC ?= ""
12ODP_SOC_ls1043ardb = "LS1043"
13ODP_SOC_ls1046ardb = "LS1046"
14ODP_PLATFORM ?= "linux-dpaa2"
15ODP_PLATFORM_ls1043ardb = "linux-dpaa1"
16ODP_PLATFORM_ls1046ardb = "linux-dpaa1"
17ODP_BUILD_TYPE ?= "ls2088"
18ODP_BUILD_TYPE_ls1043ardb = "ls1043"
19ODP_BUILD_TYPE_ls1046ardb = "ls1046"
20ODP_BUILD_TYPE_ls2080ardb = "ls2080"
21
22EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
23 --with-sdk-install-path=${STAGING_DIR_TARGET} \
24 --enable-build-type=${ODP_BUILD_TYPE} \
25 --enable-test-vald \
26 --enable-test-perf \
27 --enable-test-cpp \
28"
29
30EXTRA_OEMAKE = "CROSS_COMPILE="${TARGET_PREFIX}" \
31 SYSROOT="${STAGING_DIR_TARGET}" \
32"
33
34PACKAGECONFIG[perf] = "--enable-test-perf,,,"
35
36do_configure_prepend () {
37 export SOC=${ODP_SOC}
38 ${S}/bootstrap
39}
40
41do_compile_prepend () {
42 export SOC=${ODP_SOC}
43 export ARCH=${TUNE_ARCH}
44}
45
46do_install_append () {
47 install -d ${D}${includedir}/odp/kni
48 install -d ${D}${includedir}/odp/kern
49 install -d ${D}${includedir}/odp/flib/mc
50 install -d ${D}${includedir}/odp/flib/qbman/include/drivers
51
52 cp -rf ${S}/platform/linux-dpaa2/include/* ${D}${includedir}/odp/
53 cp -rf ${S}/platform/linux-dpaa2/kni/*.h ${D}${includedir}/odp/kni/
54 cp -rf ${S}/kern/*.h ${D}${includedir}/odp/kern/
55 cp -rf ${S}/platform/linux-dpaa2/flib/mc/*.h ${D}${includedir}/odp/flib/mc/
56 cp -rf ${S}/platform/linux-dpaa2/flib/qbman/include/drivers/*.h ${D}${includedir}/odp/flib/qbman/include/drivers
57
58 sed -i -e 's#platform/linux-dpaa2/##g' ${D}${includedir}/odp/kern/*.h
59}
60
61FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la"
62FILES_${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test"
63FILES_${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug"