summaryrefslogtreecommitdiffstats
path: root/recipes-extended/odp/odp/disable-the-Werror-flag.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/odp/odp/disable-the-Werror-flag.patch')
-rw-r--r--recipes-extended/odp/odp/disable-the-Werror-flag.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-extended/odp/odp/disable-the-Werror-flag.patch b/recipes-extended/odp/odp/disable-the-Werror-flag.patch
new file mode 100644
index 00000000..3ba1c060
--- /dev/null
+++ b/recipes-extended/odp/odp/disable-the-Werror-flag.patch
@@ -0,0 +1,19 @@
1Patch to disable the Werror flag.
2
3Werror flag is causing the code compilaton error when
4ubuntu toolchain is used to compile the code in Dash.
5This patch disables the Werror flag to avoid such errors.
6
7Signed-off-by: Sandeep Malik <Sandeep.Malik@nxp.com>
8
9--- a/configure.acold 2017-04-19 17:40:58.312258373 +0800
10+++ b/configure.ac 2017-04-19 17:41:22.820257525 +0800
11@@ -249,7 +249,7 @@
12 ##########################################################################
13 # Default warning setup
14 ##########################################################################
15-ODP_CFLAGS="$ODP_CFLAGS -W -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes"
16+ODP_CFLAGS="$ODP_CFLAGS -W -Wall -Wstrict-prototypes -Wmissing-prototypes"
17 ODP_CFLAGS="$ODP_CFLAGS -Wmissing-declarations -Wold-style-definition -Wpointer-arith"
18 ODP_CFLAGS="$ODP_CFLAGS -Wcast-align -Wnested-externs -Wcast-qual -Wformat-nonliteral"
19 ODP_CFLAGS="$ODP_CFLAGS -Wformat-security -Wundef -Wwrite-strings"