summaryrefslogtreecommitdiffstats
path: root/recipes-extended/odp/odp-counters_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/odp/odp-counters_git.bb')
-rw-r--r--recipes-extended/odp/odp-counters_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb
new file mode 100644
index 00000000..860dd5fa
--- /dev/null
+++ b/recipes-extended/odp/odp-counters_git.bb
@@ -0,0 +1,14 @@
1require odp.inc
2
3inherit module
4
5do_compile_prepend () {
6 export KERNEL_PATH="${STAGING_KERNEL_DIR}"
7 export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}"
8 cd ${S}/test/debug/perf_counters
9}
10
11do_install () {
12 install -d ${D}/lib/modules/${KERNEL_VERSION}/odp
13 install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}/lib/modules/${KERNEL_VERSION}/odp
14}