summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.29.0.bb41
-rw-r--r--recipes-dpaa2/restool/files/disable-manpage-generation.patch25
-rw-r--r--recipes-dpaa2/restool/restool_git.bb15
-rw-r--r--recipes-dpaa2/spc/spc_git.bb2
4 files changed, 77 insertions, 6 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
new file mode 100644
index 00000000..ba43b761
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
10SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-dpaa2/restool/files/disable-manpage-generation.patch b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
new file mode 100644
index 00000000..ec512830
--- /dev/null
+++ b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
@@ -0,0 +1,25 @@
1From 5392152e704ff001c41de03445d668227237a87e Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Fri, 15 Oct 2021 09:36:04 +0530
4Subject: [PATCH] disable manpage generation
5
6Signed-off-by: Ting Liu <ting.liu@nxp.com>
7---
8 Makefile | 1 -
9 1 file changed, 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index ee669ae..ab6e499 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -60,7 +60,6 @@ install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/
16 install -D -m 755 scripts/ls-debug $(DESTDIR)$(bindir)/ls-debug
17 $(foreach symlink, $(RESTOOL_SCRIPT_SYMLINKS), sh -c "cd $(DESTDIR)$(bindir) && ln -sf ls-main $(symlink)" ;)
18 install -D -m 755 scripts/restool_completion.sh $(DESTDIR)$(bindir_completion)/restool
19- install -m 0644 -D $(MANPAGE) $(call get_manpage_destination,$(MANPAGE))
20
21 clean:
22 rm -f $(OBJ) $(MANPAGE) \
23--
242.25.1
25
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 5376d8f7..3ff5afd8 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -2,14 +2,16 @@ SUMMARY = "DPAA2 Resource Manager Tool"
2LICENSE = "BSD" 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0" 3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
4 4
5RDEPENDS:${PN} += "bash dtc" 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
6 6 file://disable-manpage-generation.patch \
7SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1" 7"
8SRCREV = "8ddbe4c9559ffad5d7e5dd3cd5f00ceeff7f05d4" 8SRCREV = "d29522aef9f92ff2557978d5d3979b771a9576fe"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces"' 12inherit bash-completion
13
14EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"'
13 15
14do_install () { 16do_install () {
15 oe_runmake install DESTDIR=${D} 17 oe_runmake install DESTDIR=${D}
@@ -18,3 +20,6 @@ do_install () {
18COMPATIBLE_MACHINE = "(qoriq-arm64)" 20COMPATIBLE_MACHINE = "(qoriq-arm64)"
19PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
20 22
23RDEPENDS:${PN} += "bash dtc"
24RDEPENDS:${PN}-bash-completion += "bash"
25
diff --git a/recipes-dpaa2/spc/spc_git.bb b/recipes-dpaa2/spc/spc_git.bb
index 3e68ae89..2ef1d01d 100644
--- a/recipes-dpaa2/spc/spc_git.bb
+++ b/recipes-dpaa2/spc/spc_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=163b09a1c249a6ff2b28da1ceca2e0a8"
5DEPENDS = "libxml2 fmlib tclap" 5DEPENDS = "libxml2 fmlib tclap"
6 6
7SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/spc;nobranch=1" 7SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/spc;nobranch=1"
8SRCREV = "be7dd8e346a934aae1e4bdd6b579f2aa4bb5cd86" 8SRCREV = "398138687a3d3d6ef174501221711de74ff7bc40"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11