summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/restool
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/restool')
-rw-r--r--recipes-dpaa2/restool/restool_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
new file mode 100644
index 00000000..aad831fa
--- /dev/null
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -0,0 +1,18 @@
1SUMMARY = "DPAA2 Resource Manager Tool"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=e613b54e73c0e4a2a8918c61924bd623"
4
5RDEPENDS_${PN} += "bash"
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/restool.git;branch=sdk-v2.0.x"
8SRCREV = "eba25cdfdccef45f7ba02dd2f829b9b55198fbb1"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-Wno-missing-field-initializers -Wno-missing-braces"'
13
14do_install () {
15 oe_runmake install DESTDIR=${D}
16}
17
18COMPATIBLE_MACHINE = "(ls2080ardb)"