summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/restool/restool_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/restool/restool_git.bb')
-rw-r--r--recipes-dpaa2/restool/restool_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 5376d8f7..3ff5afd8 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -2,14 +2,16 @@ SUMMARY = "DPAA2 Resource Manager Tool"
2LICENSE = "BSD" 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0" 3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
4 4
5RDEPENDS:${PN} += "bash dtc" 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
6 6 file://disable-manpage-generation.patch \
7SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1" 7"
8SRCREV = "8ddbe4c9559ffad5d7e5dd3cd5f00ceeff7f05d4" 8SRCREV = "d29522aef9f92ff2557978d5d3979b771a9576fe"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces"' 12inherit bash-completion
13
14EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"'
13 15
14do_install () { 16do_install () {
15 oe_runmake install DESTDIR=${D} 17 oe_runmake install DESTDIR=${D}
@@ -18,3 +20,6 @@ do_install () {
18COMPATIBLE_MACHINE = "(qoriq-arm64)" 20COMPATIBLE_MACHINE = "(qoriq-arm64)"
19PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
20 22
23RDEPENDS:${PN} += "bash dtc"
24RDEPENDS:${PN}-bash-completion += "bash"
25