summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex/management-complex_10.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/management-complex/management-complex_10.3.2.bb')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.3.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.3.2.bb b/recipes-dpaa2/management-complex/management-complex_10.3.2.bb
new file mode 100644
index 00000000..84c952c6
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.3.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "Freescale-Binary-EULA"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=0ef9ba7621bd36f5fef5009fbeb56b00"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/qoriq-open-source/mc-binary.git;nobranch=1"
10SRCREV = "5e4a0d854def8cc4090cb86b26ac4ac18e7e4143"
11
12S = "${WORKDIR}/git"
13
14REGLEX_ls2088a = "ls2088a"
15REGLEX_ls1088a = "ls1088a"
16
17do_install () {
18 install -d ${D}/boot
19 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
20}
21
22do_deploy () {
23 install -d ${DEPLOYDIR}/mc_app
24 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
25 # make a symlink to the latest binary
26 for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
27 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
28 done
29}
30addtask deploy before do_build after do_install
31
32PACKAGES += "${PN}-image"
33FILES_${PN}-image += "/boot"
34
35INHIBIT_PACKAGE_STRIP = "1"
36
37COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
38PACKAGE_ARCH = "${MACHINE_ARCH}"
39