diff options
Diffstat (limited to 'recipes-dpaa2/dce')
-rw-r--r-- | recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch | 27 | ||||
-rw-r--r-- | recipes-dpaa2/dce/dce_git.bb | 19 |
2 files changed, 0 insertions, 46 deletions
diff --git a/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch b/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch deleted file mode 100644 index de8ae0c8..00000000 --- a/recipes-dpaa2/dce/dce/Makefile-obey-LDFLAGS.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | Subject: [PATCH] Makefile:Obey LDFLAGS in Makefile | ||
2 | |||
3 | This avoids a "QA Issue: No GNU_HASH in the elf binary" | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | |||
7 | Signed-off-by:Chunrong Guo <chunrong.guo@nxp.com> | ||
8 | |||
9 | --- a/Makefileold 2017-04-19 15:32:36.512525035 +0800 | ||
10 | +++ b/Makefile 2017-04-19 15:34:29.560521121 +0800 | ||
11 | @@ -46,13 +46,13 @@ | ||
12 | all: basic_dce_test basic_dce_perf basic_dce_sanity | ||
13 | |||
14 | basic_dce_test: tests/basic_dce_test.o libdce.a | ||
15 | - $(CC) $(CFLAGS) $^ -o $@ | ||
16 | + $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS) | ||
17 | |||
18 | basic_dce_perf: tests/basic_dce_perf.o libdce.a | ||
19 | - $(CC) $(CFLAGS) $^ -o $@ | ||
20 | + $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS) | ||
21 | |||
22 | basic_dce_sanity: tests/basic_dce_sanity.o libdce.a | ||
23 | - $(CC) $(CFLAGS) $^ -o $@ | ||
24 | + $(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS) | ||
25 | |||
26 | libdce.a: $(OBJS) | ||
27 | $(AR) rcs $@ $(OBJS) | ||
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb deleted file mode 100644 index 0f0b283d..00000000 --- a/recipes-dpaa2/dce/dce_git.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | DESCRIPTION = "Decompression Compression Engine Userspace Utils" | ||
2 | SECTION = "dpaa2" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3bb80dec5c1b94d99a1422cbfd96192c" | ||
5 | |||
6 | SRC_URI = "git://git.freescale.com/ppc/sdk/dce.git;nobranch=1 \ | ||
7 | file://Makefile-obey-LDFLAGS.patch \ | ||
8 | " | ||
9 | SRCREV = "c31f81667f5cebb3e5331c50655473301672e4de" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' | ||
14 | |||
15 | do_install () { | ||
16 | oe_runmake install DESTDIR=${D} | ||
17 | } | ||
18 | |||
19 | COMPATIBLE_MACHINE = "(ls2080a|ls2088a|ls1088a)" | ||