summaryrefslogtreecommitdiffstats
path: root/recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb')
-rw-r--r--recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb b/recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb
new file mode 100644
index 00000000..01cbeafa
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-loader_1.3.261.1.imx.bb
@@ -0,0 +1,42 @@
1SUMMARY = "3D graphics and compute API common loader"
2DESCRIPTION = "Vulkan is a new generation graphics and compute API \
3that provides efficient access to modern GPUs. These packages \
4provide only the common vendor-agnostic library loader, headers and \
5the vulkaninfo utility."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Loader"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;branch=main;protocol=https"
13SRCREV = "afdd025ead2b63b2c73d900ab128a2d3b512cdf0"
14
15S = "${WORKDIR}/git"
16
17REQUIRED_DISTRO_FEATURES = "vulkan"
18
19inherit cmake features_check pkgconfig
20
21DEPENDS += "vulkan-headers"
22
23EXTRA_OECMAKE = "\
24 -DBUILD_TESTS=OFF \
25 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
26 -DASSEMBLER_WORKS=FALSE \
27 -DVulkanHeaders_INCLUDE_DIR=${STAGING_INCDIR} \
28 -DVulkanRegistry_DIR=${RECIPE_SYSROOT}/${datadir} \
29 "
30
31PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
32
33PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr"
34PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
35
36RRECOMMENDS:${PN} = "mesa-vulkan-drivers"
37
38# These recipes need to be updated in lockstep with each other:
39# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
40# The tags versions should always be sdk-x.y.z, as this is what
41# upstream considers a release.
42UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"