summaryrefslogtreecommitdiffstats
path: root/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb')
-rw-r--r--recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb b/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
new file mode 100644
index 00000000..01eb14b9
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-headers_1.3.261.1.imx.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Vulkan Header files and API registry"
2DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0 & MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
13
14SRCREV = "85c2334e92e215cce34e8e0ed8b2dce4700f4a50"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES:${PN} += "${datadir}/vulkan"
21RDEPENDS:${PN} += "python3-core"
22
23# These recipes need to be updated in lockstep with each other:
24# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
25# The tags versions should always be sdk-x.y.z, as this is what
26# upstream considers a release.
27UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"