diff options
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/uuu/files/0001-remove-unnecessary-libzip-dependency.patch | 135 | ||||
-rw-r--r-- | recipes-devtools/uuu/uuu_git.bb | 6 |
2 files changed, 2 insertions, 139 deletions
diff --git a/recipes-devtools/uuu/files/0001-remove-unnecessary-libzip-dependency.patch b/recipes-devtools/uuu/files/0001-remove-unnecessary-libzip-dependency.patch deleted file mode 100644 index 52a6b880..00000000 --- a/recipes-devtools/uuu/files/0001-remove-unnecessary-libzip-dependency.patch +++ /dev/null | |||
@@ -1,135 +0,0 @@ | |||
1 | From 96ed03b04cb9a94043e44c5f5caa8825a0e89f3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Rasmus Villemoes <rasmus.villemoes@prevas.dk> | ||
3 | Date: Wed, 13 Oct 2021 10:18:50 +0200 | ||
4 | Subject: [PATCH] remove unnecessary libzip dependency | ||
5 | |||
6 | It seems that the libzip dependency has been added by mistake. See | ||
7 | full analysis in https://github.com/NXPmicro/mfgtools/issues/294 . | ||
8 | |||
9 | Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk> | ||
10 | Upstream-Status: Backport [https://github.com/NXPmicro/mfgtools/pull/295] | ||
11 | --- | ||
12 | .travis.yml | 1 - | ||
13 | README.md | 4 ++-- | ||
14 | appveyor.yml | 4 ++-- | ||
15 | libuuu/CMakeLists.txt | 1 - | ||
16 | snap/snapcraft.yaml | 2 -- | ||
17 | uuu/CMakeLists.txt | 5 ++--- | ||
18 | 6 files changed, 6 insertions(+), 11 deletions(-) | ||
19 | |||
20 | diff --git a/.travis.yml b/.travis.yml | ||
21 | index 9138aff..1d2d235 100644 | ||
22 | --- a/.travis.yml | ||
23 | +++ b/.travis.yml | ||
24 | @@ -33,7 +33,6 @@ addons: | ||
25 | packages: | ||
26 | - cmake | ||
27 | - libusb | ||
28 | - - libzip | ||
29 | - openssl | ||
30 | - pkg-config | ||
31 | |||
32 | diff --git a/README.md b/README.md | ||
33 | index 20c3f97..6910276 100644 | ||
34 | --- a/README.md | ||
35 | +++ b/README.md | ||
36 | @@ -68,7 +68,7 @@ Note that, since uuu is an OSI compliant Open Source project, you are entitled t | ||
37 | ## Linux | ||
38 | - `git clone https://github.com/NXPmicro/mfgtools.git` | ||
39 | - `cd mfgtools` | ||
40 | -- `sudo apt-get install libusb-1.0-0-dev libzip-dev libbz2-dev pkg-config cmake libssl-dev g++` | ||
41 | +- `sudo apt-get install libusb-1.0-0-dev libbz2-dev pkg-config cmake libssl-dev g++` | ||
42 | - `cmake . && make` | ||
43 | |||
44 | The above commands build mfgtools in source. To build it out of source | ||
45 | @@ -83,7 +83,7 @@ For cmake prior 3.13: | ||
46 | ## macOS | ||
47 | - `git clone https://github.com/NXPmicro/mfgtools.git` | ||
48 | - `cd mfgtools` | ||
49 | -- `brew install cmake libusb libzip openssl pkg-config` | ||
50 | +- `brew install cmake libusb openssl pkg-config` | ||
51 | - `cmake -DOPENSSL_ROOT_DIR=$(brew --prefix)/opt/openssl . && make` | ||
52 | |||
53 | Note that we assume [brew](https://brew.sh) is installed and can be used to resolve dependencies as shown above. The remaining dependency `libbz2` can be resolved via the XCode supplied libraries. | ||
54 | diff --git a/appveyor.yml b/appveyor.yml | ||
55 | index 9e1c74a..e679f84 100644 | ||
56 | --- a/appveyor.yml | ||
57 | +++ b/appveyor.yml | ||
58 | @@ -28,11 +28,11 @@ install: | ||
59 | |||
60 | - cmd: cd .. | ||
61 | |||
62 | -- sh: if [ "${APPVEYOR_BUILD_WORKER_IMAGE}" = "macOS" ]; then brew install libusb libzip pkg-config; fi | ||
63 | +- sh: if [ "${APPVEYOR_BUILD_WORKER_IMAGE}" = "macOS" ]; then brew install libusb pkg-config; fi | ||
64 | |||
65 | - sh: if [ "${APPVEYOR_BUILD_WORKER_IMAGE}" != "macOS" ]; then sudo apt-get update; fi | ||
66 | |||
67 | -- sh: if [ "${APPVEYOR_BUILD_WORKER_IMAGE}" != "macOS" ]; then sudo DEBIAN_FRONTEND=noninteractive apt-get --yes --force-yes install libusb-1.0-0-dev libzip-dev libbz2-dev asciidoc rename; fi | ||
68 | +- sh: if [ "${APPVEYOR_BUILD_WORKER_IMAGE}" != "macOS" ]; then sudo DEBIAN_FRONTEND=noninteractive apt-get --yes --force-yes install libusb-1.0-0-dev libbz2-dev asciidoc rename; fi | ||
69 | |||
70 | build_script: | ||
71 | |||
72 | diff --git a/libuuu/CMakeLists.txt b/libuuu/CMakeLists.txt | ||
73 | index f4390a7..2ace072 100644 | ||
74 | --- a/libuuu/CMakeLists.txt | ||
75 | +++ b/libuuu/CMakeLists.txt | ||
76 | @@ -7,7 +7,6 @@ set(CMAKE_SKIP_RPATH ON) | ||
77 | find_package(BZip2 REQUIRED) | ||
78 | find_package(PkgConfig REQUIRED) | ||
79 | pkg_check_modules(LIBUSB REQUIRED libusb-1.0>=1.0.16) | ||
80 | -pkg_check_modules(LIBZIP REQUIRED libzip) | ||
81 | find_package(Threads) | ||
82 | |||
83 | if (STATIC) | ||
84 | diff --git a/snap/snapcraft.yaml b/snap/snapcraft.yaml | ||
85 | index 09b9065..8a98cca 100644 | ||
86 | --- a/snap/snapcraft.yaml | ||
87 | +++ b/snap/snapcraft.yaml | ||
88 | @@ -103,14 +103,12 @@ parts: | ||
89 | - libbz2-dev | ||
90 | - libusb-1.0-0-dev | ||
91 | - libssl-dev | ||
92 | - - libzip-dev | ||
93 | - pkg-config | ||
94 | plugin: cmake | ||
95 | stage-packages: | ||
96 | - libbz2-1.0 | ||
97 | - libusb-1.0-0 | ||
98 | - libssl1.0.0 | ||
99 | - - libzip4 | ||
100 | filesets: | ||
101 | docs-copyright: | ||
102 | - usr/share/doc/*/copyright | ||
103 | diff --git a/uuu/CMakeLists.txt b/uuu/CMakeLists.txt | ||
104 | index b57a67e..ab78529 100644 | ||
105 | --- a/uuu/CMakeLists.txt | ||
106 | +++ b/uuu/CMakeLists.txt | ||
107 | @@ -6,7 +6,6 @@ set(CMAKE_SKIP_RPATH ON) | ||
108 | |||
109 | find_package(PkgConfig REQUIRED) | ||
110 | pkg_check_modules(LIBUSB REQUIRED libusb-1.0>=1.0.16) | ||
111 | -pkg_check_modules(LIBZIP REQUIRED libzip) | ||
112 | pkg_check_modules(LIBZ REQUIRED zlib) | ||
113 | find_package(Threads) | ||
114 | |||
115 | @@ -34,7 +33,7 @@ set(LSTS | ||
116 | nand_burn_loader.lst | ||
117 | ) | ||
118 | |||
119 | -link_directories(${CMAKE_CURRENT_SOURCE_DIR}/libuuu ${LIBUSB_LIBRARY_DIRS} ${LIBZIP_LIBRARY_DIRS} ${LIBZ_LIBRARY_DIRS}) | ||
120 | +link_directories(${CMAKE_CURRENT_SOURCE_DIR}/libuuu ${LIBUSB_LIBRARY_DIRS} ${LIBZ_LIBRARY_DIRS}) | ||
121 | |||
122 | set(CLIST_EXECUTABLE ${CMAKE_CURRENT_SOURCE_DIR}/gen_txt_include.sh) | ||
123 | set(generated_files_dir "${CMAKE_BINARY_DIR}/uuu/gen") | ||
124 | @@ -70,7 +69,7 @@ set(SOURCES | ||
125 | ) | ||
126 | |||
127 | add_executable(uuu ${SOURCES}) | ||
128 | -target_link_libraries(uuu uuc_s ${OPENSSL_LIBRARIES} ${LIBUSB_LIBRARIES} ${LIBZIP_LIBRARIES} ${LIBZ_LIBRARIES} dl bz2) | ||
129 | +target_link_libraries(uuu uuc_s ${OPENSSL_LIBRARIES} ${LIBUSB_LIBRARIES} ${LIBZ_LIBRARIES} dl bz2) | ||
130 | |||
131 | install(TARGETS uuu DESTINATION bin) | ||
132 | target_compile_definitions(uuu | ||
133 | -- | ||
134 | 2.31.1 | ||
135 | |||
diff --git a/recipes-devtools/uuu/uuu_git.bb b/recipes-devtools/uuu/uuu_git.bb index caa349b2..08fa51c2 100644 --- a/recipes-devtools/uuu/uuu_git.bb +++ b/recipes-devtools/uuu/uuu_git.bb | |||
@@ -3,10 +3,8 @@ DESCRIPTION = "Image deploy tool for i.MX chips" | |||
3 | HOMEPAGE = "https://github.com/NXPmicro/mfgtools" | 3 | HOMEPAGE = "https://github.com/NXPmicro/mfgtools" |
4 | 4 | ||
5 | SRC_URI = "git://github.com/NXPmicro/mfgtools.git;protocol=https;branch=master" | 5 | SRC_URI = "git://github.com/NXPmicro/mfgtools.git;protocol=https;branch=master" |
6 | SRCREV = "e10b0260076e0119c259f7f44447904f14109ba2" | 6 | SRCREV = "ed48c514ee4c1ea4562c875877b180a87474f895" |
7 | PV = "1.4.165" | 7 | PV = "1.4.243" |
8 | |||
9 | SRC_URI += "file://0001-remove-unnecessary-libzip-dependency.patch" | ||
10 | 8 | ||
11 | LICENSE = "BSD-3-Clause" | 9 | LICENSE = "BSD-3-Clause" |
12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38ec0c18112e9a92cffc4951661e85a5" | 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38ec0c18112e9a92cffc4951661e85a5" |