summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/uuu/uuu-bin_1.5.165.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/uuu/uuu-bin_1.5.165.bb')
-rw-r--r--recipes-devtools/uuu/uuu-bin_1.5.165.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-devtools/uuu/uuu-bin_1.5.165.bb b/recipes-devtools/uuu/uuu-bin_1.5.165.bb
new file mode 100644
index 00000000..2b5feda1
--- /dev/null
+++ b/recipes-devtools/uuu/uuu-bin_1.5.165.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2022-2023 O.S. Systems Software LTDA.
2# Released under the MIT License (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Update Utility - Binaries"
5DESCRIPTION = "Image deploy tool for i.MX chips"
6HOMEPAGE = "https://github.com/nxp-imx/mfgtools"
7
8LICENSE = "BSD-3-Clause & LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
10 file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68"
11
12SRC_URI = " \
13 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu;downloadfilename=uuu-${PV};name=Linux \
14 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu_mac;downloadfilename=uuu-${PV}_mac;name=Mac \
15 https://github.com/nxp-imx/mfgtools/releases/download/uuu_${PV}/uuu.exe;downloadfilename=uuu-${PV}.exe;name=Windows \
16"
17
18SRC_URI[Linux.sha256sum] = "f863bba022202361d19e5026be0af408d307f78d2dbf2c139fb7eaaabd220442"
19SRC_URI[Mac.sha256sum] = "62da0bd7e333931fba100823aa50133621c7e6047be0546bc12e29c0ea78a4d8"
20SRC_URI[Windows.sha256sum] = "013ed8bb45e21b971b6b3a5802c5f154733913714bece0b020cb770a809cd206"
21
22S = "${WORKDIR}"
23
24inherit allarch
25
26do_install() {
27 install -D -m 0755 ${WORKDIR}/uuu-${PV} ${D}${libdir}/uuu/uuu
28 install -D -m 0755 ${WORKDIR}/uuu-${PV}_mac ${D}${libdir}/uuu/uuu_mac
29 install -D -m 0644 ${WORKDIR}/uuu-${PV}.exe ${D}${libdir}/uuu/uuu.exe
30}
31
32# HACK! We are not aiming to run those binaries during the build but copy then for MFGTOOL bundle.
33INSANE_SKIP:${PN} += "arch file-rdeps"
34FILES:${PN} = "${libdir}/uuu"
35SYSROOT_DIRS = "${libdir}/uuu"