summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/utp-com/utp-com_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/utp-com/utp-com_git.bb')
-rw-r--r--recipes-devtools/utp-com/utp-com_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb
new file mode 100644
index 00000000..163f5852
--- /dev/null
+++ b/recipes-devtools/utp-com/utp-com_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Tool used to send commands to hardware via NXP's UTP protocol"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
4
5DEPENDS = "sg3-utils"
6
7SRCREV = "7fe590fef812561cceb08aaa10b64e9bac8f542f"
8SRC_URI = " \
9 git://github.com/ixonos/utp_com;protocol=https \
10 file://0001-Fix-Makefile-for-crosscompilation.patch \
11"
12
13PV = "1.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile () {
20 oe_runmake
21}
22
23do_install () {
24 install -d -m 0755 ${D}${bindir}
25 install -m 0755 ${S}/utp_com ${D}${bindir}/utp_com
26}
27
28BBCLASSEXTEND = "native nativesdk"