summaryrefslogtreecommitdiffstats
path: root/recipes-daemons/ptpd/ptpd-qoriq.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-daemons/ptpd/ptpd-qoriq.bb')
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
index df3787b2..f3a7f0ce 100644
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ b/recipes-daemons/ptpd/ptpd-qoriq.bb
@@ -14,6 +14,15 @@ PROVIDES = "ptpd"
14 14
15inherit autotools pkgconfig systemd 15inherit autotools pkgconfig systemd
16 16
17python() {
18 pkgs = d.getVar('PACKAGES', True).split()
19 for p in pkgs:
20 if 'ptpd-qoriq' in p:
21 d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
22 d.appendVar("RCONFLICTS_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
23 d.appendVar("RREPLACES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
24}
25
17# return something like '1.2.3' or '1.2.3/rc1' 26# return something like '1.2.3' or '1.2.3/rc1'
18# 27#
19def get_sub(d): 28def get_sub(d):