summaryrefslogtreecommitdiffstats
path: root/recipes-daemons/ptpd/ptpd-qoriq.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-daemons/ptpd/ptpd-qoriq.bb')
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
deleted file mode 100644
index 569deed5..00000000
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1SUMMARY = "The PTP daemon (PTPd)"
2DESCRIPTION = "The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as \
3defined by the relevant IEEE 1588 standard. PTP Version 1 implements IEEE-1588-2002, \
4and PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise \
5time coordination of LAN connected computers."
6HOMEPAGE = "http://sourceforge.net/projects/ptpd"
7SECTION = "net"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://README;md5=0733e1b3788ab2ebbc63bf33a020da1d"
10
11COMPATIBLE_MACHINE = "(qoriq)"
12
13DEPENDS = "libpcap"
14
15PROVIDES = "ptpd"
16
17inherit autotools pkgconfig systemd
18
19python() {
20 pkgs = d.getVar('PACKAGES').split()
21 for p in pkgs:
22 if 'ptpd-qoriq' in p:
23 d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
24 d.appendVar("RCONFLICTS_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
25 d.appendVar("RREPLACES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
26}
27
28# return something like '1.2.3' or '1.2.3/rc1'
29#
30def get_sub(d):
31 parts = d.getVar('PV').split('-')
32 try:
33 return parts[0] + '/' + parts[1]
34 except:
35 return parts[0]
36
37SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ptpd;nobranch=1 \
38 file://ptpd-use-pkgconfig.patch \
39"
40SRCREV = "ec34cdd10446619d036ac8d6a86b8276f0d4a81c"
41
42S = "${WORKDIR}/git"
43
44EXTRA_OEMAKE = ""
45
46EXTRA_OECONF += "--disable-snmp --with-pcap-config=pkg-config"
47
48do_install() {
49 install -d ${D}${bindir} ${D}${mandir}/man8
50 install -m 0755 ${B}/src/ptpd2 ${D}${bindir}
51 install -m 0644 ${B}/src/ptpd2.8 ${D}${mandir}/man8
52
53 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
54 install -d ${D}${systemd_unitdir}/system
55 install -m 0644 ${WORKDIR}/ptpd.service ${D}${systemd_unitdir}/system
56
57 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/ptpd.service
58 sed -i -e 's#@BINDIR@#${bindir}#g' ${D}${systemd_unitdir}/system/ptpd.service
59
60 install -d ${D}${sysconfdir}/default/
61 install -m 0644 ${WORKDIR}/ptpd.conf ${D}${sysconfdir}/default/ptpd
62 fi
63}
64
65SYSTEMD_PACKAGES = "${PN}"
66SYSTEMD_SERVICE_${PN} = "ptpd.service"
67SYSTEMD_AUTO_ENABLE = "disable"