summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb62
1 files changed, 0 insertions, 62 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb
deleted file mode 100644
index b4cdb7d2..00000000
--- a/recipes-connectivity/openssl/openssl-qoriq_1.0.2l.bb
+++ /dev/null
@@ -1,62 +0,0 @@
1require openssl-qoriq.inc
2
3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
6DEPENDS += "cryptodev-linux"
7
8CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225"
11
12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}"
14
15SRC_URI += "file://find.pl;subdir=git/util \
16 file://run-ptest \
17 file://openssl-c_rehash.sh \
18 file://configure-targets.patch \
19 file://shared-libs.patch \
20 file://oe-ldflags.patch \
21 file://engines-install-in-libdir-ssl.patch \
22 file://debian1.0.2/block_diginotar.patch \
23 file://debian1.0.2/block_digicert_malaysia.patch \
24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://debian1.0.2/soname.patch \
34 file://openssl_fix_for_x32.patch \
35 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
36 file://openssl-fix-des.pod-error.patch \
37 file://Makefiles-ptest.patch \
38 file://ptest-deps.patch \
39 file://ptest_makefile_deps.patch \
40 file://configure-musl-target.patch \
41 file://parallel.patch \
42 file://openssl-util-perlpath.pl-cwd.patch \
43 file://Use-SHA256-not-MD5-as-default-digest.patch \
44 file://0001-Fix-build-with-clang-using-external-assembler.patch \
45 "
46SRCREV = "b9e6572a0dcbaaf84a8925cabd1a86bd594ca69f"
47
48PACKAGES =+ "${PN}-engines"
49FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
50
51# The crypto_use_bigint patch means that perl's bignum module needs to be
52# installed, but some distributions (for example Fedora 23) don't ship it by
53# default. As the resulting error is very misleading check for bignum before
54# building.
55do_configure_prepend() {
56 if ! perl -Mbigint -e true; then
57 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
58 fi
59}
60
61PARALLEL_MAKE = ""
62COMPATIBLE_MACHINE = "(qoriq)"