summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb51
1 files changed, 32 insertions, 19 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
index 9ba150ad..c7064977 100644
--- a/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.2k.bb
@@ -1,36 +1,56 @@
1require openssl-qoriq.inc 1require openssl-qoriq.inc
2 2
3
4DISABLE_STATIC = "" 3DISABLE_STATIC = ""
4# For target side versions of openssl enable support for OCF Linux driver
5# if they are available.
5DEPENDS += "cryptodev-linux" 6DEPENDS += "cryptodev-linux"
6RRECOMMENDS_libcrypto += "cryptodev-module" 7
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" 8CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8COMPATIBLE_MACHINE = "(qoriq)"
9 9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
11 11
12export DIRS = "crypto ssl apps engines" 12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}" 13export OE_LDFLAGS="${LDFLAGS}"
14 14
15SRC_URI += "file://find.pl \ 15SRC_URI += "file://find.pl;subdir=${BP}/util/ \
16 file://run-ptest \ 16 file://run-ptest \
17 file://openssl-c_rehash.sh \
17 file://configure-targets.patch \ 18 file://configure-targets.patch \
18 file://shared-libs.patch \ 19 file://shared-libs.patch \
19 file://oe-ldflags.patch \ 20 file://oe-ldflags.patch \
20 file://engines-install-in-libdir-ssl.patch \ 21 file://engines-install-in-libdir-ssl.patch \
21 file://debian1.0.2/block_diginotar.patch \ 22 file://debian1.0.2/block_diginotar.patch \
22 file://debian1.0.2/block_digicert_malaysia.patch \ 23 file://debian1.0.2/block_digicert_malaysia.patch \
23 file://no-rpath.patch \ 24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://debian1.0.2/soname.patch \
24 file://openssl_fix_for_x32.patch \ 34 file://openssl_fix_for_x32.patch \
25 file://fix-cipher-des-ede3-cfb1.patch \ 35 file://fix-cipher-des-ede3-cfb1.patch \
36 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
26 file://openssl-fix-des.pod-error.patch \ 37 file://openssl-fix-des.pod-error.patch \
27 file://Makefiles-ptest.patch \ 38 file://Makefiles-ptest.patch \
28 file://ptest-deps.patch \ 39 file://ptest-deps.patch \
29 file://crypto_use_bigint_in_x86-64_perl.patch \
30 file://openssl-1.0.2a-x32-asm.patch \ 40 file://openssl-1.0.2a-x32-asm.patch \
31 file://ptest_makefile_deps.patch \ 41 file://ptest_makefile_deps.patch \
32 " 42 file://configure-musl-target.patch \
33SRC_URI += "file://0001-remove-double-initialization-of-cryptodev-engine.patch \ 43 file://parallel.patch \
44 file://openssl-util-perlpath.pl-cwd.patch \
45 file://Use-SHA256-not-MD5-as-default-digest.patch \
46 file://0001-Fix-build-with-clang-using-external-assembler.patch \
47 "
48SRC_URI[md5sum] = "f965fc0bf01bf882b31314b61391ae65"
49SRC_URI[sha256sum] = "6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0"
50
51SRC_URI += " \
52 file://find.pl;subdir=openssl-${PV}/util/ \
53 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
34 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \ 54 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
35 file://0003-cryptodev-fix-algorithm-registration.patch \ 55 file://0003-cryptodev-fix-algorithm-registration.patch \
36 file://0004-ECC-Support-header-for-Cryptodev-Engine.patch \ 56 file://0004-ECC-Support-header-for-Cryptodev-Engine.patch \
@@ -80,16 +100,8 @@ SRC_URI += "file://0001-remove-double-initialization-of-cryptodev-engine.patch \
80 file://0048-fix-maclen-is-used-uninitialized-warning-on-some-com.patch \ 100 file://0048-fix-maclen-is-used-uninitialized-warning-on-some-com.patch \
81" 101"
82 102
83SRC_URI[md5sum] = "f965fc0bf01bf882b31314b61391ae65" 103PACKAGES =+ "${PN}-engines"
84SRC_URI[sha256sum] = "6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0"
85
86PACKAGES =+ " \
87 ${PN}-engines \
88 ${PN}-engines-dbg \
89 "
90
91FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" 104FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
92FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
93 105
94# The crypto_use_bigint patch means that perl's bignum module needs to be 106# The crypto_use_bigint patch means that perl's bignum module needs to be
95# installed, but some distributions (for example Fedora 23) don't ship it by 107# installed, but some distributions (for example Fedora 23) don't ship it by
@@ -99,5 +111,6 @@ do_configure_prepend() {
99 if ! perl -Mbigint -e true; then 111 if ! perl -Mbigint -e true; then
100 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake." 112 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
101 fi 113 fi
102 cp ${WORKDIR}/find.pl ${S}/util/find.pl
103} 114}
115
116COMPATIBLE_MACHINE = "(qoriq)"