summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb111
1 files changed, 111 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb b/recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb
new file mode 100644
index 00000000..deb4fd7c
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-qoriq_1.0.2h.bb
@@ -0,0 +1,111 @@
1require openssl-qoriq.inc
2
3DISABLE_STATIC = ""
4RRECOMMENDS_libcrypto += "cryptodev-module"
5COMPATIBLE_MACHINE = "(qoriq)"
6
7# For target side versions of openssl enable support for OCF Linux driver
8# if they are available.
9DEPENDS += "cryptodev-linux"
10
11CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
12
13LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
14
15export DIRS = "crypto ssl apps engines"
16export OE_LDFLAGS="${LDFLAGS}"
17
18SRC_URI += "file://find.pl;subdir=${BP}/util/ \
19 file://run-ptest \
20 file://openssl-c_rehash.sh \
21 file://configure-targets.patch \
22 file://shared-libs.patch \
23 file://oe-ldflags.patch \
24 file://engines-install-in-libdir-ssl.patch \
25 file://debian1.0.2/block_diginotar.patch \
26 file://debian1.0.2/block_digicert_malaysia.patch \
27 file://debian/ca.patch \
28 file://debian/c_rehash-compat.patch \
29 file://debian/debian-targets.patch \
30 file://debian/man-dir.patch \
31 file://debian/man-section.patch \
32 file://debian/no-rpath.patch \
33 file://debian/no-symbolic.patch \
34 file://debian/pic.patch \
35 file://debian1.0.2/version-script.patch \
36 file://openssl_fix_for_x32.patch \
37 file://fix-cipher-des-ede3-cfb1.patch \
38 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
39 file://openssl-fix-des.pod-error.patch \
40 file://Makefiles-ptest.patch \
41 file://ptest-deps.patch \
42 file://openssl-1.0.2a-x32-asm.patch \
43 file://ptest_makefile_deps.patch \
44 file://configure-musl-target.patch \
45 file://parallel.patch \
46 "
47SRC_URI += "file://0001-remove-double-initialization-of-cryptodev-engine.patch \
48 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
49 file://0003-cryptodev-fix-algorithm-registration.patch \
50 file://0004-ECC-Support-header-for-Cryptodev-Engine.patch \
51 file://0005-Initial-support-for-PKC-in-cryptodev-engine.patch \
52 file://0006-Added-hwrng-dev-file-as-source-of-RNG.patch \
53 file://0007-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
54 file://0008-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
55 file://0009-RSA-Keygen-Fix.patch \
56 file://0010-Removed-local-copy-of-curve_t-type.patch \
57 file://0011-Modulus-parameter-is-not-populated-by-dhparams.patch \
58 file://0012-SW-Backoff-mechanism-for-dsa-keygen.patch \
59 file://0013-Fixed-DH-keygen-pair-generator.patch \
60 file://0014-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
61 file://0015-eng_cryptodev-extend-TLS-offload-with-3des_cbc_hmac_.patch \
62 file://0016-eng_cryptodev-add-support-for-TLSv1.1-record-offload.patch \
63 file://0017-eng_cryptodev-add-support-for-TLSv1.2-record-offload.patch \
64 file://0018-cryptodev-drop-redundant-function.patch \
65 file://0019-cryptodev-do-not-zero-the-buffer-before-use.patch \
66 file://0020-cryptodev-clean-up-code-layout.patch \
67 file://0021-cryptodev-do-not-cache-file-descriptor-in-open.patch \
68 file://0022-cryptodev-put_dev_crypto-should-be-an-int.patch \
69 file://0023-cryptodev-simplify-cryptodev-pkc-support-code.patch \
70 file://0024-cryptodev-clarify-code-remove-assignments-from-condi.patch \
71 file://0025-cryptodev-clean-up-context-state-before-anything-els.patch \
72 file://0026-cryptodev-remove-code-duplication-in-digest-operatio.patch \
73 file://0027-cryptodev-put-all-digest-ioctls-into-a-single-functi.patch \
74 file://0028-cryptodev-fix-debug-print-messages.patch \
75 file://0029-cryptodev-use-CIOCHASH-ioctl-for-digest-operations.patch \
76 file://0030-cryptodev-reduce-duplicated-efforts-for-searching-in.patch \
77 file://0031-cryptodev-remove-not-used-local-variables.patch \
78 file://0032-cryptodev-hide-not-used-variable-behind-ifndef.patch \
79 file://0033-cryptodev-fix-function-declaration-typo.patch \
80 file://0034-cryptodev-fix-incorrect-function-signature.patch \
81 file://0035-cryptodev-fix-warnings-on-excess-elements-in-struct-.patch \
82 file://0036-cryptodev-fix-free-on-error-path.patch \
83 file://0037-cryptodev-fix-return-value-on-error.patch \
84 file://0038-cryptodev-match-types-with-cryptodev.h.patch \
85 file://0039-cryptodev-explicitly-discard-const-qualifier.patch \
86 file://0040-cryptodev-replace-caddr_t-with-void.patch \
87 file://0041-cryptodev-check-for-errors-inside-cryptodev_rsa_mod_.patch \
88 file://0042-cryptodev-check-for-errors-inside-cryptodev_rsa_mod_.patch \
89 file://0043-cryptodev-check-for-errors-inside-cryptodev_dh_compu.patch \
90 file://0044-cryptodev-check-for-errors-inside-cryptodev_dh_compu.patch \
91 file://0045-cryptodev-change-signature-for-conversion-functions.patch \
92 file://0046-cryptodev-add-explicit-cast-for-known-BIGNUM-values.patch \
93 file://0047-cryptodev-treat-all-build-warnings-as-errors.patch \
94 file://0048-fix-maclen-is-used-uninitialized-warning-on-some-com.patch \
95"
96
97SRC_URI[md5sum] = "9392e65072ce4b614c1392eefc1f23d0"
98SRC_URI[sha256sum] = "1d4007e53aad94a5b2002fe045ee7bb0b3d98f1a47f8b2bc851dcd1c74332919"
99
100PACKAGES =+ "${PN}-engines"
101FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
102
103# The crypto_use_bigint patch means that perl's bignum module needs to be
104# installed, but some distributions (for example Fedora 23) don't ship it by
105# default. As the resulting error is very misleading check for bignum before
106# building.
107do_configure_prepend() {
108 if ! perl -Mbigint -e true; then
109 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
110 fi
111}