summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch')
-rw-r--r--recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch88
1 files changed, 0 insertions, 88 deletions
diff --git a/recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch b/recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch
deleted file mode 100644
index 1ab585c2..00000000
--- a/recipes-connectivity/openssl/openssl-qoriq/Makefiles-ptest.patch
+++ /dev/null
@@ -1,88 +0,0 @@
1From 5a871ad1f426f7ed3952588ecec61d2304e66a80 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Tue, 20 Mar 2018 11:39:29 +0800
4Subject: [PATCH] Makefiles-ptest
5
6Add 'buildtest' and 'runtest' targets to Makefile, to build and run tests
7cross-compiled.
8
9Signed-off-by: Anders Roxell <anders.roxell@enea.com>
10Signed-off-by: Maxin B. John <maxin.john@enea.com>
11Upstream-Status: Pending
12---
13 Makefile.org | 10 +++++++++-
14 test/Makefile | 12 ++++++++----
15 2 files changed, 17 insertions(+), 5 deletions(-)
16
17diff --git a/Makefile.org b/Makefile.org
18index 111fbba..9f24777 100644
19--- a/Makefile.org
20+++ b/Makefile.org
21@@ -468,8 +468,16 @@ rehash.time: certs apps
22 test: tests
23
24 tests: rehash
25+ $(MAKE) buildtest
26+ $(MAKE) runtest
27+
28+buildtest:
29+ @(cd test && \
30+ $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf exe apps);
31+
32+runtest:
33 @(cd test && echo "testing..." && \
34- $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf tests );
35+ $(CLEARENV) && $(MAKE) -e $(BUILDENV) TOP=.. TESTS='$(TESTS)' OPENSSL_DEBUG_MEMORY=on OPENSSL_CONF=../apps/openssl.cnf alltests );
36 OPENSSL_CONF=apps/openssl.cnf util/opensslwrap.sh version -a
37
38 report:
39diff --git a/test/Makefile b/test/Makefile
40index 74d8fc2..34f17fc 100644
41--- a/test/Makefile
42+++ b/test/Makefile
43@@ -149,7 +149,7 @@ tests: exe apps $(TESTS)
44 apps:
45 @(cd ..; $(MAKE) DIRS=apps all)
46
47-alltests: \
48+alltests= \
49 test_des test_idea test_sha test_md4 test_md5 test_hmac \
50 test_md2 test_mdc2 test_wp \
51 test_rmd test_rc2 test_rc4 test_rc5 test_bf test_cast test_aes \
52@@ -160,6 +160,10 @@ alltests: \
53 test_jpake test_srp test_cms test_ocsp test_v3name test_heartbeat \
54 test_constant_time test_verify_extra test_clienthello test_sslv2conftest \
55 test_dtls test_bad_dtls
56+alltests:
57+ @(for i in $(all-tests); do \
58+ ( $(MAKE) $$i && echo "PASS: $$i" ) || echo "FAIL: $$i"; \
59+ done)
60
61 test_evp: $(EVPTEST)$(EXE_EXT) evptests.txt
62 ../util/shlib_wrap.sh ./$(EVPTEST) evptests.txt
63@@ -229,7 +233,7 @@ test_x509: ../apps/openssl$(EXE_EXT) tx509 testx509.pem v3-cert1.pem v3-cert2.pe
64 echo test second x509v3 certificate
65 sh ./tx509 v3-cert2.pem 2>/dev/null
66
67-test_rsa: $(RSATEST)$(EXE_EXT) ../apps/openssl$(EXE_EXT) trsa testrsa.pem
68+test_rsa: ../apps/openssl$(EXE_EXT) trsa testrsa.pem
69 @sh ./trsa 2>/dev/null
70 ../util/shlib_wrap.sh ./$(RSATEST)
71
72@@ -330,11 +334,11 @@ test_tsa: ../apps/openssl$(EXE_EXT) testtsa CAtsa.cnf ../util/shlib_wrap.sh
73 sh ./testtsa; \
74 fi
75
76-test_ige: $(IGETEST)$(EXE_EXT)
77+test_ige:
78 @echo "Test IGE mode"
79 ../util/shlib_wrap.sh ./$(IGETEST)
80
81-test_jpake: $(JPAKETEST)$(EXE_EXT)
82+test_jpake:
83 @echo "Test JPAKE"
84 ../util/shlib_wrap.sh ./$(JPAKETEST)
85
86--
872.7.4
88