summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb6
-rw-r--r--recipes-bsp/rcw/rcw_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb6
3 files changed, 7 insertions, 7 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index 1af630a6..9bac32d9 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -11,9 +11,9 @@ SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13python () { 13python () {
14 if not d.getVar("QE_UCODE", True): 14 if not d.getVar("QE_UCODE"):
15 PN = d.getVar("PN", True) 15 PN = d.getVar("PN")
16 FILE = os.path.basename(d.getVar("FILE", True)) 16 FILE = os.path.basename(d.getVar("FILE"))
17 bb.debug(1, "To build %s, see %s for instructions on \ 17 bb.debug(1, "To build %s, see %s for instructions on \
18 setting up your qe-ucode" % (PN, FILE)) 18 setting up your qe-ucode" % (PN, FILE))
19 raise bb.parse.SkipRecipe("because QE_UCODE is not set") 19 raise bb.parse.SkipRecipe("because QE_UCODE is not set")
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index c6bdad23..007e7d25 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15export PYTHON = "${USRBINPATH}/python2" 15export PYTHON = "${USRBINPATH}/python2"
16 16
17M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}" 17M="${@d.getVar('MACHINE').replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
18 18
19do_install () { 19do_install () {
20 if [ ${M} = ls2088ardb ]; then 20 if [ ${M} = ls2088ardb ]; then
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
index 8438134d..f48dc81f 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
@@ -11,11 +11,11 @@ DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
11DEPENDS_append_qoriq-ppc = " boot-format-native" 11DEPENDS_append_qoriq-ppc = " boot-format-native"
12 12
13python () { 13python () {
14 if d.getVar("TCMODE", True) == "external-fsl": 14 if d.getVar("TCMODE") == "external-fsl":
15 return 15 return
16 16
17 ml = d.getVar("MULTILIB_VARIANTS", True) 17 ml = d.getVar("MULTILIB_VARIANTS")
18 arch = d.getVar("OVERRIDES", True) 18 arch = d.getVar("OVERRIDES")
19 19
20 if "e5500-64b:" in arch or "e6500-64b:" in arch: 20 if "e5500-64b:" in arch or "e6500-64b:" in arch:
21 if not "lib32" in ml: 21 if not "lib32" in ml: