diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index 5c20fac8..71f8b25d 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -65,12 +65,16 @@ SOC_FAMILY = "INVALID" | |||
65 | SOC_FAMILY:mx8-generic-bsp = "mx8" | 65 | SOC_FAMILY:mx8-generic-bsp = "mx8" |
66 | SOC_FAMILY:mx8m-generic-bsp = "mx8m" | 66 | SOC_FAMILY:mx8m-generic-bsp = "mx8m" |
67 | SOC_FAMILY:mx8x-generic-bsp = "mx8x" | 67 | SOC_FAMILY:mx8x-generic-bsp = "mx8x" |
68 | SOC_FAMILY:mx8ulp-nxp-bsp = "mx8ulp" | ||
68 | 69 | ||
69 | REV_OPTION ?= "" | 70 | REV_OPTION ?= "" |
70 | REV_OPTION:mx8qxp-generic-bsp = \ | 71 | REV_OPTION:mx8qxp-generic-bsp = \ |
71 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ | 72 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ |
72 | 'REV=C0', d)}" | 73 | 'REV=C0', d)}" |
73 | REV_OPTION:mx8dx-generic-bsp = "REV=C0" | 74 | REV_OPTION:mx8dx-generic-bsp = "REV=C0" |
75 | REV_OPTION:mx8ulp-generic-bsp = \ | ||
76 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-reva0', '', \ | ||
77 | 'REV=A1', d)}" | ||
74 | 78 | ||
75 | do_uboot_assemble_fitimage:prepend:imx-generic-bsp() { | 79 | do_uboot_assemble_fitimage:prepend:imx-generic-bsp() { |
76 | for config in ${UBOOT_MACHINE}; do | 80 | for config in ${UBOOT_MACHINE}; do |
@@ -121,6 +125,19 @@ compile_mx8x() { | |||
121 | ${BOOT_STAGING}/u-boot-spl.bin | 125 | ${BOOT_STAGING}/u-boot-spl.bin |
122 | fi | 126 | fi |
123 | } | 127 | } |
128 | |||
129 | compile_mx8ulp() { | ||
130 | bbnote 8ULP boot binary build | ||
131 | cp ${DEPLOY_DIR_IMAGE}/${SECO_FIRMWARE_NAME} ${BOOT_STAGING}/ | ||
132 | cp ${DEPLOY_DIR_IMAGE}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin | ||
133 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/upower.bin ${BOOT_STAGING}/upower.bin | ||
134 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin | ||
135 | if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ] ; then | ||
136 | cp ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ | ||
137 | ${BOOT_STAGING}/u-boot-spl.bin | ||
138 | fi | ||
139 | } | ||
140 | |||
124 | do_compile() { | 141 | do_compile() { |
125 | # mkimage for i.MX8 | 142 | # mkimage for i.MX8 |
126 | # Copy TEE binary to SoC target folder to mkimage | 143 | # Copy TEE binary to SoC target folder to mkimage |
@@ -180,6 +197,17 @@ deploy_mx8x() { | |||
180 | ${DEPLOYDIR}/${BOOT_TOOLS} | 197 | ${DEPLOYDIR}/${BOOT_TOOLS} |
181 | fi | 198 | fi |
182 | } | 199 | } |
200 | |||
201 | deploy_mx8ulp() { | ||
202 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | ||
203 | install -m 0644 ${BOOT_STAGING}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
204 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
205 | if [ -e ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ] ; then | ||
206 | install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ | ||
207 | ${DEPLOYDIR}/${BOOT_TOOLS} | ||
208 | fi | ||
209 | } | ||
210 | |||
183 | do_deploy() { | 211 | do_deploy() { |
184 | deploy_${SOC_FAMILY} | 212 | deploy_${SOC_FAMILY} |
185 | # copy the sc fw, dcd and uboot to deploy path | 213 | # copy the sc fw, dcd and uboot to deploy path |