summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8.23.inc17
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8.24.inc17
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_8.24.bb (renamed from recipes-bsp/firmware-imx/firmware-imx_8.23.bb)25
-rw-r--r--recipes-bsp/firmware-imx/imx-boot-firmware-files_8.24.bb (renamed from recipes-bsp/firmware-imx/imx-boot-firmware-files_8.23.bb)0
-rw-r--r--recipes-bsp/imx-lib/imx-lib_git.bb2
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb3
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb7
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.1.bb (renamed from recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.0.bb)5
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.9.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.6.bb)3
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.28.0.bb36
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb41
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_5.4.39.3.bb1
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb8
13 files changed, 93 insertions, 72 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8.23.inc b/recipes-bsp/firmware-imx/firmware-imx-8.23.inc
deleted file mode 100644
index bd471f77..00000000
--- a/recipes-bsp/firmware-imx/firmware-imx-8.23.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SECTION = "base"
5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
7
8SRC_URI = " \
9 ${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \
10"
11
12SRC_URI[md5sum] = "eb03efb3a8fb98d99ed1df88537e72f4"
13SRC_URI[sha256sum] = "fe07633295dac3dd99f0ba4e07a7cde95bb24a29ca82b9a9b3f6026d29ae916a"
14
15S = "${WORKDIR}/firmware-imx-${PV}"
16
17inherit fsl-eula-unpack
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8.24.inc b/recipes-bsp/firmware-imx/firmware-imx-8.24.inc
new file mode 100644
index 00000000..9e9d10dc
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-imx-8.24.inc
@@ -0,0 +1,17 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright 2017-2023 NXP
3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SECTION = "base"
5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=10c0fda810c63b052409b15a5445671a"
7
8# Note: This .inc file is used from differently named recipes, so the package
9# name must be hard-coded, i.e., ${BPN} cannot be used.
10SRC_URI = "${FSL_MIRROR}/firmware-imx-${PV}-${IMX_SRCREV_ABBREV}.bin;fsl-eula=true"
11IMX_SRCREV_ABBREV = "fbe0a4c"
12SRC_URI[md5sum] = "440b125e897614d77fac663d90bcffc8"
13SRC_URI[sha256sum] = "2e27962332197ebebbb30138f6dfb365361d48d7efa565df97c4f79285b1ca50"
14
15S = "${WORKDIR}/firmware-imx-${PV}-${IMX_SRCREV_ABBREV}"
16
17inherit fsl-eula-unpack
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.23.bb b/recipes-bsp/firmware-imx/firmware-imx_8.24.bb
index a9e36b5e..489174d0 100644
--- a/recipes-bsp/firmware-imx/firmware-imx_8.23.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx_8.24.bb
@@ -1,23 +1,30 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP 2# Copyright 2017-2021,2023 NXP
3# Copyright (C) 2018 O.S. Systems Software LTDA. 3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SUMMARY = "Freescale i.MX firmware" 4SUMMARY = "Freescale i.MX firmware"
5DESCRIPTION = "Freescale i.MX firmware such as for the VPU" 5DESCRIPTION = "Freescale i.MX firmware such as for the VPU"
6 6
7require firmware-imx-${PV}.inc 7require ${BP}.inc
8 8
9PE = "1" 9PE = "1"
10 10
11inherit allarch 11inherit allarch
12 12
13IMX_USE_LINUX_FIRMWARE_SDMA ?= "1"
14
13do_install() { 15do_install() {
14 install -d ${D}${nonarch_base_libdir}/firmware/imx 16 install -d ${D}${nonarch_base_libdir}/firmware/imx
15 17
16 # SDMA Firmware section 18 # SDMA Firmware section
17 install -d ${D}${nonarch_base_libdir}/firmware/imx/sdma 19 install -d ${D}${nonarch_base_libdir}/firmware/imx/sdma
18 install -m 0644 ${S}/firmware/sdma/* ${D}${nonarch_base_libdir}/firmware/imx/sdma 20 install -m 0644 ${S}/firmware/sdma/* ${D}${nonarch_base_libdir}/firmware/imx/sdma
19 rm -f ${D}${nonarch_base_libdir}/firmware/imx/sdma/sdma-imx6q.bin 21 # Define IMX_USE_LINUX_FIRMWARE_SDMA = "0" in layer.conf, machine.conf, local.conf
20 rm -f ${D}${nonarch_base_libdir}/firmware/imx/sdma/sdma-imx7d.bin 22 # or in .bbappend to use sdma-imx6q/7d.bin from here and not linux-firmware
23 if [ ${IMX_USE_LINUX_FIRMWARE_SDMA} -gt 0 ]
24 then
25 rm -f ${D}${nonarch_base_libdir}/firmware/imx/sdma/sdma-imx6q.bin
26 rm -f ${D}${nonarch_base_libdir}/firmware/imx/sdma/sdma-imx7d.bin
27 fi
21 28
22 # EASRC Firmware section 29 # EASRC Firmware section
23 install -d ${D}${nonarch_base_libdir}/firmware/imx/easrc 30 install -d ${D}${nonarch_base_libdir}/firmware/imx/easrc
@@ -53,6 +60,11 @@ do_install() {
53 # as some of other files are provided by packages from other recipes. 60 # as some of other files are provided by packages from other recipes.
54 install -d ${D}${nonarch_base_libdir}/firmware/vpu 61 install -d ${D}${nonarch_base_libdir}/firmware/vpu
55 install -m 0644 ${S}/firmware/vpu/vpu_fw_imx*.bin ${D}${nonarch_base_libdir}/firmware/vpu 62 install -m 0644 ${S}/firmware/vpu/vpu_fw_imx*.bin ${D}${nonarch_base_libdir}/firmware/vpu
63 # Update i.MX8 vpu firmware path to align with kernel6.5+
64 install -d ${D}${nonarch_base_libdir}/firmware/amphion/vpu/
65 mv ${D}${nonarch_base_libdir}/firmware/vpu/vpu_fw_imx8* ${D}${nonarch_base_libdir}/firmware/amphion/vpu/
66 # Install i.MX 95 VPU firmware
67 install -m 0644 ${S}/firmware/vpu/wave633c_codec_fw.bin ${D}${nonarch_base_libdir}/firmware
56} 68}
57 69
58# 70#
@@ -88,6 +100,7 @@ python populate_packages:prepend() {
88 100
89 os.chdir(cwd) 101 os.chdir(cwd)
90 102
103
91 easrcdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/easrc', d) 104 easrcdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/easrc', d)
92 do_split_packages(d, easrcdir, '^easrc-([^_]*).*\.bin', 105 do_split_packages(d, easrcdir, '^easrc-([^_]*).*\.bin',
93 output_pattern='firmware-imx-easrc-%s', 106 output_pattern='firmware-imx-easrc-%s',
@@ -144,7 +157,7 @@ PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-* ${PN}-easrc-* ${PN}-xcvr-* ${PN}-xu
144# is empty. 157# is empty.
145# Therefore, we opt-out from producing -dev package here, since also for firmware 158# Therefore, we opt-out from producing -dev package here, since also for firmware
146# files it makes no sense. 159# files it makes no sense.
147PACKAGES = "${PN} ${PN}-epdc ${PN}-hdmi" 160PACKAGES = "${PN} ${PN}-epdc ${PN}-hdmi ${PN}-vpu-amphion ${PN}-vpu-wave"
148 161
149FILES:${PN}-epdc = "${nonarch_base_libdir}/firmware/imx/epdc/" 162FILES:${PN}-epdc = "${nonarch_base_libdir}/firmware/imx/epdc/"
150FILES:${PN}-hdmi = " \ 163FILES:${PN}-hdmi = " \
@@ -152,5 +165,7 @@ FILES:${PN}-hdmi = " \
152 ${nonarch_base_libdir}/firmware/hdmirxfw.bin \ 165 ${nonarch_base_libdir}/firmware/hdmirxfw.bin \
153 ${nonarch_base_libdir}/firmware/dpfw.bin \ 166 ${nonarch_base_libdir}/firmware/dpfw.bin \
154" 167"
168FILES:${PN}-vpu-amphion = "${nonarch_base_libdir}/firmware/amphion/vpu/*"
169FILES:${PN}-vpu-wave = "${nonarch_base_libdir}/firmware/wave633c_codec_fw.bin"
155 170
156COMPATIBLE_MACHINE = "(imx-generic-bsp)" 171COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.23.bb b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.24.bb
index 24619859..24619859 100644
--- a/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.23.bb
+++ b/recipes-bsp/firmware-imx/imx-boot-firmware-files_8.24.bb
diff --git a/recipes-bsp/imx-lib/imx-lib_git.bb b/recipes-bsp/imx-lib/imx-lib_git.bb
index 74b7bddf..d06ccfa1 100644
--- a/recipes-bsp/imx-lib/imx-lib_git.bb
+++ b/recipes-bsp/imx-lib/imx-lib_git.bb
@@ -13,7 +13,7 @@ PE = "1"
13PV = "5.9+${SRCPV}" 13PV = "5.9+${SRCPV}"
14 14
15SRC_URI = "git://github.com/nxp-imx/imx-lib.git;protocol=https;branch=${SRCBRANCH}" 15SRC_URI = "git://github.com/nxp-imx/imx-lib.git;protocol=https;branch=${SRCBRANCH}"
16SRCBRANCH = "lf-6.1.55_2.2.0" 16SRCBRANCH = "lf-6.6.3_1.0.0"
17SRCREV = "8f124c3914d82019849fb697baeb730e4cb1b547" 17SRCREV = "8f124c3914d82019849fb697baeb730e4cb1b547"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index a761870b..7792b27b 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -58,7 +58,8 @@ IMXBOOT_TARGETS ?= \
58BOOT_STAGING = "${S}/${IMX_BOOT_SOC_TARGET}" 58BOOT_STAGING = "${S}/${IMX_BOOT_SOC_TARGET}"
59BOOT_STAGING:mx8m-generic-bsp = "${S}/iMX8M" 59BOOT_STAGING:mx8m-generic-bsp = "${S}/iMX8M"
60BOOT_STAGING:mx8dx-generic-bsp = "${S}/iMX8QX" 60BOOT_STAGING:mx8dx-generic-bsp = "${S}/iMX8QX"
61BOOT_STAGING:mx9-generic-bsp = "${S}/iMX9" 61BOOT_STAGING:mx91p-generic-bsp = "${S}/iMX91"
62BOOT_STAGING:mx93-generic-bsp = "${S}/iMX93"
62 63
63SOC_FAMILY = "INVALID" 64SOC_FAMILY = "INVALID"
64SOC_FAMILY:mx8-generic-bsp = "mx8" 65SOC_FAMILY:mx8-generic-bsp = "mx8"
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index 5d30179d..930cdf94 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -13,14 +13,15 @@ DEPENDS:append:imxvpu = " virtual/imxvpu"
13DEPENDS:append:mx6-nxp-bsp = " imx-lib" 13DEPENDS:append:mx6-nxp-bsp = " imx-lib"
14DEPENDS:append:mx7-nxp-bsp = " imx-lib" 14DEPENDS:append:mx7-nxp-bsp = " imx-lib"
15DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib" 15DEPENDS:append:mx8ulp-nxp-bsp = " imx-lib"
16DEPENDS:append:mx93-nxp-bsp = " imx-lib"
16 17
17PE = "1" 18PE = "1"
18PV = "7.0+${SRCPV}" 19PV = "7.0+${SRCPV}"
19 20
20SRC_URI = "git://github.com/nxp-imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21SRC_URI = "git://github.com/nxp-imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
21 file://memtool_profile" 22 file://memtool_profile"
22SRCBRANCH = "lf-6.1.55_2.2.0" 23SRCBRANCH = "lf-6.6.3_1.0.0"
23SRCREV = "e8b3c9026553233491abb4df4185dd7291a8ffb2" 24SRCREV = "8a1fa37664a1e470cf86f1185c08e265e4602a9b"
24 25
25S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
26 27
@@ -39,6 +40,8 @@ PLATFORM:mx7d-nxp-bsp = "IMX7D"
39PLATFORM:mx7ulp-nxp-bsp = "IMX7D" 40PLATFORM:mx7ulp-nxp-bsp = "IMX7D"
40PLATFORM:mx8-nxp-bsp = "IMX8" 41PLATFORM:mx8-nxp-bsp = "IMX8"
41PLATFORM:mx8ulp-nxp-bsp = "IMX8ULP" 42PLATFORM:mx8ulp-nxp-bsp = "IMX8ULP"
43PLATFORM:mx93-nxp-bsp = "IMX8ULP"
44PLATFORM:mx95-nxp-bsp = "IMX8"
42 45
43PARALLEL_MAKE = "-j 1" 46PARALLEL_MAKE = "-j 1"
44EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" 47EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}"
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.1.bb
index 26ebf181..76dd55b8 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.9.1.bb
@@ -2,7 +2,7 @@
2 2
3DESCRIPTION = "i.MX VC8000E Encoder library" 3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" 5LIC_FILES_CHKSUM = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
6 6
7inherit fsl-eula-unpack 7inherit fsl-eula-unpack
8 8
@@ -10,8 +10,7 @@ SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10 10
11S = "${WORKDIR}/${BPN}-${PV}" 11S = "${WORKDIR}/${BPN}-${PV}"
12 12
13SRC_URI[md5sum] = "192b354d1c21836dc7338606e60b45ae" 13SRC_URI[sha256sum] = "84fcefa0619def2f009ca6651c5cffcda57fed29cd7060ef68be48c5d0d7814b"
14SRC_URI[sha256sum] = "62b5ba3c4aab21d0d4be3eee9b204a9bb50b83b6140ee1a3b27c648809bdfbaa"
15 14
16# SCR is the location and name of the Software Content Register file 15# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}. 16# relative to ${D}${D_SUBDIR}.
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.6.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.9.bb
index f603190b..ee10518c 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.6.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.9.bb
@@ -7,8 +7,7 @@ DEPENDS = "imx-vpu-hantro"
7DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" 7DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
8 8
9SRC_URI = "${FSL_MIRROR}/${BP}.tar.gz" 9SRC_URI = "${FSL_MIRROR}/${BP}.tar.gz"
10SRC_URI[md5sum] = "23997361dab3054e5a3757a15d33db16" 10SRC_URI[sha256sum] = "80d6620063fd5e5506b05c907677b579d471a9b6daa8b26ffb963110cc680bf9"
11SRC_URI[sha256sum] = "ac2b60fb754792eedcfdfc8cf59663cfeaedc402857eff13ac97a911d2c65801"
12 11
13PLATFORM:mx8mm-nxp-bsp = "IMX8MM" 12PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
14PLATFORM:mx8mq-nxp-bsp = "IMX8MQ" 13PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.28.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.28.0.bb
deleted file mode 100644
index 0757a7fb..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.28.0.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ea25d099982d035af85d193c88a1b479"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "81b4eb801349a0c198b7cc43eb8b6097"
11SRC_URI[sha256sum] = "e868e12945b4f217e2e0511fdc2587875d6c9124e8673b67f1e7de367ff5012f"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
18PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
19PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb
new file mode 100644
index 00000000..2a35f9ac
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[sha256sum] = "f751ab7369d48e610ea3b6b0dc5a885c70a510861d6b46296ffc063fed370003"
11
12inherit fsl-eula-unpack use-imx-headers
13
14PARALLEL_MAKE="-j 1"
15
16PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
17PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
18PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
19
20#| ../../source/h264high/h264decapi.c:1803:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types]
21#| 1803 | ref_data = ref.virtual_address;
22#| ../../source/h264high/h264decapi.c:2086:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types]
23#| 2086 | ref_data = ref.virtual_address;
24
25CFLAGS += " -Wno-error=incompatible-pointer-types"
26EXTRA_OEMAKE = " \
27 CROSS_COMPILE="${HOST_PREFIX}" \
28 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
29 PLATFORM="${PLATFORM}" \
30"
31
32do_install () {
33 oe_runmake install DEST_DIR="${D}"
34}
35
36FILES:${PN} += "/unit_tests"
37
38RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
39
40PACKAGE_ARCH = "${MACHINE_SOCARCH}"
41COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.39.3.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.39.3.bb
index 383a0e2a..553f3993 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_5.4.39.3.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.39.3.bb
@@ -7,7 +7,6 @@ LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9" 7LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
8 8
9PROVIDES = "virtual/imxvpu" 9PROVIDES = "virtual/imxvpu"
10RPROVIDES:${PN} = "virtual/imxvpu"
11 10
12PE = "1" 11PE = "1"
13 12
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index c01bfd4c..bb542e8c 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -13,10 +13,10 @@ SRCREV = "f55ee9f72090309bbb7ab71f48a498fc02909234"
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15do_install () { 15do_install () {
16 install -d ${D}/lib/firmware 16 install -d ${D}${nonarch_base_libdir}/firmware
17 install -d ${D}/boot/engine-pfe-bin 17 install -d ${D}/boot/engine-pfe-bin
18 install -m 644 ${S}/NXP-Binary-EULA.txt ${D}/lib/firmware 18 install -m 644 ${S}/NXP-Binary-EULA.txt ${D}${nonarch_base_libdir}/firmware
19 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware 19 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}${nonarch_base_libdir}/firmware
20 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin 20 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin
21} 21}
22 22
@@ -27,7 +27,7 @@ do_deploy () {
27 27
28addtask deploy after do_install 28addtask deploy after do_install
29 29
30FILES:${PN} += "/lib/firmware /boot/" 30FILES:${PN} += "${nonarch_base_libdir}/firmware /boot/"
31INSANE_SKIP:${PN} += "arch already-stripped" 31INSANE_SKIP:${PN} += "arch already-stripped"
32INHIBIT_PACKAGE_STRIP = "1" 32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1" 33INHIBIT_SYSROOT_STRIP = "1"