diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq-common_2019.10.inc | 27 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb | 28 |
2 files changed, 27 insertions, 28 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq-common_2019.10.inc b/recipes-bsp/u-boot/u-boot-qoriq-common_2019.10.inc deleted file mode 100644 index bc2eaa4d..00000000 --- a/recipes-bsp/u-boot/u-boot-qoriq-common_2019.10.inc +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | |||
2 | inherit fsl-u-boot-localversion | ||
3 | |||
4 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \ | ||
8 | file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \ | ||
9 | file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
10 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ | ||
11 | " | ||
12 | |||
13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \ | ||
14 | file://0001-patman-Drop-binary-parameter.patch \ | ||
15 | file://0001-patman-Update-command.Run-to-handle-failure-better.patch \ | ||
16 | file://0001-patman-Adjust-command-to-return-strings-instead-of-b.patch \ | ||
17 | file://0001-pylibfdt-Convert-to-Python-3.patch \ | ||
18 | file://0001-binman-Convert-a-few-tests-to-Python-3.patch \ | ||
19 | file://0001-binman-Move-to-use-Python-3.patch \ | ||
20 | file://0001-buildman-Convert-to-Python-3.patch \ | ||
21 | " | ||
22 | SRCREV= "3cd9bc39934825200822855574fc91d8276e6584" | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | B = "${WORKDIR}/build" | ||
26 | PV_append = "+fslgit" | ||
27 | LOCALVERSION = "+fsl" | ||
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb b/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb index 8d79e17a..e0d71ebb 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2019.10.bb | |||
@@ -1,9 +1,35 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | 1 | require recipes-bsp/u-boot/u-boot.inc |
2 | require u-boot-qoriq-common_${PV}.inc | ||
3 | 2 | ||
4 | DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" | 3 | DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" |
5 | PROVIDES += "u-boot" | 4 | PROVIDES += "u-boot" |
6 | 5 | ||
6 | inherit fsl-u-boot-localversion | ||
7 | |||
8 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" | ||
9 | LIC_FILES_CHKSUM = " \ | ||
10 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
11 | file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \ | ||
12 | file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \ | ||
13 | file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
14 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ | ||
15 | " | ||
16 | |||
17 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \ | ||
18 | file://0001-patman-Drop-binary-parameter.patch \ | ||
19 | file://0001-patman-Update-command.Run-to-handle-failure-better.patch \ | ||
20 | file://0001-patman-Adjust-command-to-return-strings-instead-of-b.patch \ | ||
21 | file://0001-pylibfdt-Convert-to-Python-3.patch \ | ||
22 | file://0001-binman-Convert-a-few-tests-to-Python-3.patch \ | ||
23 | file://0001-binman-Move-to-use-Python-3.patch \ | ||
24 | file://0001-buildman-Convert-to-Python-3.patch \ | ||
25 | " | ||
26 | SRCREV= "3cd9bc39934825200822855574fc91d8276e6584" | ||
27 | |||
28 | S = "${WORKDIR}/git" | ||
29 | B = "${WORKDIR}/build" | ||
30 | PV_append = "+fslgit" | ||
31 | LOCALVERSION = "+fsl" | ||
32 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | 33 | INHIBIT_DEFAULT_DEPS = "1" |
8 | DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python3-native" | 34 | DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python3-native" |
9 | DEPENDS_append_qoriq-arm64 = " dtc-native" | 35 | DEPENDS_append_qoriq-arm64 = " dtc-native" |