diff options
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb | 45 |
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb deleted file mode 100644 index 82763eb9..00000000 --- a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | require u-boot-fslc-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" | ||
4 | DEPENDS += "mtd-utils" | ||
5 | |||
6 | INSANE_SKIP_${PN} = "already-stripped" | ||
7 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1' | ||
8 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' | ||
9 | |||
10 | inherit uboot-config | ||
11 | |||
12 | do_compile () { | ||
13 | oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE} | ||
14 | oe_runmake -C ${S} O=${B} envtools | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | install -d ${D}${base_sbindir} | ||
19 | install -d ${D}${sysconfdir} | ||
20 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv | ||
21 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv | ||
22 | |||
23 | if [ -e ${WORKDIR}/fw_env.config ]; then | ||
24 | install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
25 | else | ||
26 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
27 | fi | ||
28 | } | ||
29 | |||
30 | do_install_class-cross () { | ||
31 | install -d ${D}${bindir_cross} | ||
32 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv | ||
33 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv | ||
34 | } | ||
35 | |||
36 | SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" | ||
37 | uboot_fw_utils_cross() { | ||
38 | sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} | ||
39 | } | ||
40 | |||
41 | PROVIDES += "u-boot-fw-utils" | ||
42 | RPROVIDES_${PN} += "u-boot-fw-utils" | ||
43 | |||
44 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
45 | BBCLASSEXTEND = "cross" | ||