diff options
Diffstat (limited to 'recipes-bsp')
3 files changed, 35 insertions, 45 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch b/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch deleted file mode 100644 index 3fb9d4ef..00000000 --- a/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From d2e35983281a811b38e540ab82e7643322e84aab Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
3 | Date: Wed, 4 Dec 2019 14:17:50 +0000 | ||
4 | Subject: [PATCH] mxc_v4l2_test: fix compilation error produced by gcc9 | ||
5 | |||
6 | Fix trivial compilation error when GCC9 is used: | ||
7 | |||
8 | error: call to '__open_missing_mode' declared with attribute error: open | ||
9 | with O_CREAT or O_TMPFILE in second argument needs 3 arguments | ||
10 | |||
11 | This is now caused by not explicitly supplying the mode when O_CREAT is | ||
12 | used as disposition. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
17 | --- | ||
18 | test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | 4 ---- | ||
19 | 1 file changed, 4 deletions(-) | ||
20 | |||
21 | diff --git a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
22 | index 6e10744..d63b2db 100644 | ||
23 | --- a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
24 | +++ b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | ||
25 | @@ -561,11 +561,7 @@ static int open_save_file(struct video_channel *video_ch) | ||
26 | |||
27 | for (i = 0; i < NUM_SENSORS; i++) { | ||
28 | if ((g_cam >> i) & 0x01) { | ||
29 | -#ifdef BUILD_FOR_ANDROID | ||
30 | fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT, 0660); | ||
31 | -#else | ||
32 | - fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT); | ||
33 | -#endif | ||
34 | if (fd < 0) { | ||
35 | v4l2_err("Channel[%d] unable to create recording file\n", i); | ||
36 | while (i) | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch new file mode 100644 index 00000000..1fe997d7 --- /dev/null +++ b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 97a55fe4b1e02b9a4992517234a8b24f8f9f0009 Mon Sep 17 00:00:00 2001 | ||
2 | From: "i.MX Yocto Project Build" <imx.build@nxp.com> | ||
3 | Date: Mon, 27 Jan 2020 13:43:47 -0600 | ||
4 | Subject: [PATCH] pxp test: Fix format-security error | ||
5 | |||
6 | | pxp_lib_test/pxp_test.c: In function 'main': | ||
7 | | pxp_lib_test/pxp_test.c:541:2: error: format not a string literal and no format arguments [-Werror=format-security] | ||
8 | | 541 | printf(usage); | ||
9 | | | ^~~~~~ | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | ||
14 | --- | ||
15 | test/pxp_lib_test/pxp_test.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/test/pxp_lib_test/pxp_test.c b/test/pxp_lib_test/pxp_test.c | ||
19 | index 107198f..72c984d 100644 | ||
20 | --- a/test/pxp_lib_test/pxp_test.c | ||
21 | +++ b/test/pxp_lib_test/pxp_test.c | ||
22 | @@ -538,6 +538,6 @@ int main(int argc, char *argv[]) | ||
23 | |||
24 | return 0; | ||
25 | usage: | ||
26 | - printf(usage); | ||
27 | + printf("%s", usage); | ||
28 | return -1; | ||
29 | } | ||
30 | -- | ||
31 | 2.17.1 | ||
32 | |||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 61f5e9d4..b9c12e18 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -16,13 +16,13 @@ DEPENDS_append_imxvpu = " virtual/imxvpu" | |||
16 | PE = "1" | 16 | PE = "1" |
17 | PV = "7.0+${SRCPV}" | 17 | PV = "7.0+${SRCPV}" |
18 | 18 | ||
19 | SRCBRANCH = "lf-5.4.y" | 19 | SRCBRANCH = "imx_5.4.47_2.2.0" |
20 | SRC_URI = " \ | 20 | SRC_URI = " \ |
21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | 21 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ |
22 | file://0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch \ | 22 | file://0001-pxp-test-Fix-format-security-error.patch \ |
23 | file://memtool_profile \ | 23 | file://memtool_profile \ |
24 | " | 24 | " |
25 | SRCREV = "6d20e84f2dbe5940fe6d629c2839e1390994ee1f" | 25 | SRCREV = "31623a4972bf6f2f4239b4667aeb33baba07a3c8" |
26 | S = "${WORKDIR}/git" | 26 | S = "${WORKDIR}/git" |
27 | 27 | ||
28 | inherit module-base use-imx-headers | 28 | inherit module-base use-imx-headers |
@@ -49,9 +49,6 @@ PACKAGECONFIG_append_imxvpu = " vpu" | |||
49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | 49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" |
50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" | 50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" |
51 | 51 | ||
52 | # FIXME: Fail to build due to misuse of printf | ||
53 | SECURITY_STRINGFORMAT = "" | ||
54 | |||
55 | do_compile() { | 52 | do_compile() { |
56 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 53 | CFLAGS="${TOOLCHAIN_OPTIONS}" |
57 | oe_runmake V=1 VERBOSE='' \ | 54 | oe_runmake V=1 VERBOSE='' \ |