summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common.inc20
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb9
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2019.04.bb19
3 files changed, 30 insertions, 18 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-common.inc b/recipes-bsp/u-boot/u-boot-imx-common.inc
new file mode 100644
index 00000000..2d5105ee
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx-common.inc
@@ -0,0 +1,20 @@
1DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
2
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRCBRANCH = "imx_v2019.04_4.19.35_1.1.0"
7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
8SRCREV = "4d377539a1190e838eae5d8b8a794dde0696d572"
9
10DEPENDS += "flex-native bison-native bc-native dtc-native"
11
12S = "${WORKDIR}/git"
13B = "${WORKDIR}/build"
14
15inherit fsl-u-boot-localversion
16
17LOCALVERSION ?= "-${SRCBRANCH}"
18
19BOOT_TOOLS = "imx-boot-tools"
20
diff --git a/recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb
new file mode 100644
index 00000000..56d0a7f0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb
@@ -0,0 +1,9 @@
1require recipes-bsp/u-boot/u-boot-tools.inc
2require u-boot-imx-common.inc
3
4PROVIDES_append_class-target = " ${MLPREFIX}u-boot-tools"
5PROVIDES_append_class-native = " u-boot-tools-native"
6PROVIDES_append_class-nativesdk = " nativesdk-u-boot-tools"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9COMPATIBLE_MACHINE_class-target = "(mx6|mx7|mx8)"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
index 9b12482d..4cfcb471 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
@@ -2,28 +2,11 @@
2# Copyright 2018 (C) O.S. Systems Software LTDA. 2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017-2019 NXP 3# Copyright 2017-2019 NXP
4 4
5DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
6require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRCBRANCH = "imx_v2019.04_4.19.35_1.1.0"
14SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
15SRCREV = "4d377539a1190e838eae5d8b8a794dde0696d572"
16
17DEPENDS += "flex-native bison-native bc-native dtc-native"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23LOCALVERSION ?= "-${SRCBRANCH}"
24
25BOOT_TOOLS = "imx-boot-tools"
26
27do_deploy_append_mx8m() { 10do_deploy_append_mx8m() {
28 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 11 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
29 if [ -n "${UBOOT_CONFIG}" ] 12 if [ -n "${UBOOT_CONFIG}" ]