summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb8
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2023.01.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb13
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2022.04.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-mfgtool.inc21
5 files changed, 2 insertions, 44 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb
deleted file mode 100644
index 2e79166b..00000000
--- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright 2017-2019 NXP
4
5FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-fslc:"
6
7require u-boot-fslc_${PV}.bb
8require u-boot-mfgtool.inc
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
index f6164a76..eba8876a 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
@@ -10,7 +10,7 @@ inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'im
10 10
11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native" 11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
12 12
13PROVIDES += "u-boot" 13PROVIDES += "u-boot u-boot-mfgtool"
14 14
15B = "${WORKDIR}/build" 15B = "${WORKDIR}/build"
16 16
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb
deleted file mode 100644
index d9d5b9d5..00000000
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright 2017-2019 NXP
4
5# Re-use the u-boot-imx recipe and its files
6require u-boot-imx_${PV}.bb
7FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:"
8
9require u-boot-mfgtool.inc
10
11UUU_BOOTLOADER_TAGGED = ""
12UUU_BOOTLOADER_TAGGED:mx6-nxp-bsp = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
13UUU_BOOTLOADER_TAGGED:mx7-nxp-bsp = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
index c8119fdb..e76c29c6 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
@@ -5,7 +5,7 @@
5require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common_${PV}.inc 6require u-boot-imx-common_${PV}.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot u-boot-mfgtool"
9 9
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
diff --git a/recipes-bsp/u-boot/u-boot-mfgtool.inc b/recipes-bsp/u-boot/u-boot-mfgtool.inc
deleted file mode 100644
index 92d055bf..00000000
--- a/recipes-bsp/u-boot/u-boot-mfgtool.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1# Produces a Manufacturing Tool compatible U-Boot
2#
3# This makes a separated binary set for Manufacturing Tool use
4# without clobbering the U-Boot used for normal use.
5#
6# This file must to be included after the original u-boot.inc file,
7# as it overrides the need values.
8#
9# Copyright (C) 2014 O.S. Systems Software LTDA.
10
11# Adjust provides
12PROVIDES = "u-boot-mfgtool"
13
14# Use 'mfgtool' config
15UBOOT_CONFIG = "mfgtool"
16
17# Add 'mfgtool' suffix
18UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}"
20SPL_IMAGE = "${SPL_BINARYNAME}-${MACHINE}-mfgtool-${PV}-${PR}"
21SPL_SYMLINK = "${SPL_BINARYNAME}-mfgtool-${MACHINE}"