summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb b/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb
new file mode 100644
index 00000000..5bde945d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2017.03.bb
@@ -0,0 +1,93 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
4PROVIDES += "u-boot"
5LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
6LIC_FILES_CHKSUM = " \
7 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
9 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
10 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
11 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
12"
13
14PV_append = "+fslgit"
15INHIBIT_DEFAULT_DEPS = "1"
16DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc"
17DEPENDS_append_qoriq-arm64 = " change-file-endianess-native dtc-native tcl-native"
18DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
19DEPENDS_append_qoriq-ppc = " boot-format-native"
20
21SRC_URI = "git://github.com/qoriq-open-source/u-boot.git;nobranch=1 \
22 file://fix-build-error-under-gcc6.patch \
23"
24SRCREV = "6fc2946a7b1973a8221cdfeccd1666f2d8eec467"
25
26S = "${WORKDIR}/git"
27
28python () {
29 if d.getVar("TCMODE", True) == "external-fsl":
30 return
31
32 ml = d.getVar("MULTILIB_VARIANTS", True)
33 arch = d.getVar("OVERRIDES", True)
34
35 if "e5500-64b:" in arch or "e6500-64b:" in arch:
36 if not "lib32" in ml:
37 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
38 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux'
39 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
40 workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib)
41 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
42 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib)
43 d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot')
44 d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-')
45 elif "fsl-lsch2-32b:" in arch:
46 if not "lib64" in ml:
47 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
48 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux'
49 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
50 workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib)
51 d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc')
52 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib)
53 d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot')
54 d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-')
55}
56
57WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
58EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
59EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
60
61inherit fsl-u-boot-localversion
62LOCALVERSION = "+fsl"
63
64do_compile_append_qoriq() {
65 unset i j k
66 for config in ${UBOOT_MACHINE}; do
67 i=`expr $i + 1`;
68 for type in ${UBOOT_CONFIG}; do
69 j=`expr $j + 1`;
70 for binary in ${UBOOT_BINARIES}; do
71 k=`expr $k + 1`
72 if [ $j -eq $i ] && [ $k -eq $i ]; then
73 if [ -n "${BOOTFORMAT_CONFIG}" ] && echo "${type}" |grep -q spi;then
74 # regenerate spi binary if BOOTFORMAT_CONFIG is set
75 boot_format ${STAGING_DATADIR_NATIVE}/boot_format/${BOOTFORMAT_CONFIG} \
76 ${config}/u-boot-${type}.${UBOOT_SUFFIX} -spi ${config}/u-boot.format.bin
77 cp ${config}/u-boot.format.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX}
78 elif [ "qspi" = "${type}" ];then
79 cp ${config}/${binary} ${config}/u-boot-${type}-${PV}-${PR}.${UBOOT_SUFFIX}
80 fi
81 fi
82 done
83 unset k
84 done
85 unset j
86 done
87 unset i
88}
89
90
91PACKAGES += "${PN}-images"
92FILES_${PN}-images += "/boot"
93COMPATIBLE_MACHINE = "(qoriq)"