summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2022.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2022.04.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
new file mode 100644
index 00000000..21883af8
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright (C) 2017-2021 NXP
4
5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common_${PV}.inc
7
8PROVIDES += "u-boot"
9
10inherit uuu_bootloader_tag
11
12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6-nxp-bsp = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7-nxp-bsp = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7-nxp-bsp = "u-boot-tagged.${UBOOT_SUFFIX}"
18
19do_deploy:append:mx8m-nxp-bsp() {
20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
21 if [ -n "${UBOOT_CONFIG}" ]
22 then
23 for config in ${UBOOT_MACHINE}; do
24 i=$(expr $i + 1);
25 for type in ${UBOOT_CONFIG}; do
26 j=$(expr $j + 1);
27 if [ $j -eq $i ]
28 then
29 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
30 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
31 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
32 fi
33 done
34 unset j
35 done
36 unset i
37 fi
38}
39
40PACKAGE_ARCH = "${MACHINE_ARCH}"
41COMPATIBLE_MACHINE = "(mx6-generic-bsp|mx7-generic-bsp|mx8-generic-bsp)"