summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2020.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2020.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2020.04.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb
new file mode 100644
index 00000000..b36730e0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb
@@ -0,0 +1,32 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright (C) 2017-2020 NXP
4
5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common.inc
7
8PROVIDES += "u-boot"
9
10do_deploy_append_mx8m() {
11 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
12 if [ -n "${UBOOT_CONFIG}" ]
13 then
14 for config in ${UBOOT_MACHINE}; do
15 i=$(expr $i + 1);
16 for type in ${UBOOT_CONFIG}; do
17 j=$(expr $j + 1);
18 if [ $j -eq $i ]
19 then
20 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
23 fi
24 done
25 unset j
26 done
27 unset i
28 fi
29}
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"