diff options
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2020.10.bb')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2020.10.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2020.10.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2020.10.bb new file mode 100644 index 00000000..2492f450 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2020.10.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | require u-boot-fslc-common_${PV}.inc | ||
2 | |||
3 | DESCRIPTION = "U-boot bootloader mxsboot tool" | ||
4 | SECTION = "bootloader" | ||
5 | |||
6 | DEPENDS = "bison-native dtc openssl" | ||
7 | |||
8 | PROVIDES = "u-boot-mxsboot" | ||
9 | |||
10 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | ||
11 | EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | ||
12 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | ||
13 | |||
14 | do_compile () { | ||
15 | oe_runmake -C ${S} O=${B} sandbox_defconfig | ||
16 | |||
17 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and | ||
18 | # generating it requires bin2header tool, which for target build | ||
19 | # is built with target tools and thus cannot be executed on host. | ||
20 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config | ||
21 | |||
22 | oe_runmake -C ${S} O=${B} cross_tools NO_SDL=1 | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot | ||
27 | ln -sf uboot-mxsboot ${D}${bindir}/mxsboot | ||
28 | } | ||
29 | |||
30 | COMPATIBLE_MACHINE_class-target = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" | ||
31 | |||
32 | BBCLASSEXTEND = "native nativesdk" | ||