summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
new file mode 100644
index 00000000..7c2864ed
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
@@ -0,0 +1,46 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
5
6DEPENDS_append = " mtd-utils"
7
8INSANE_SKIP_${PN} = "already-stripped"
9EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
10EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
11
12inherit uboot-config
13
14do_compile () {
15 oe_runmake ${UBOOT_MACHINE}
16 oe_runmake env
17}
18
19do_install () {
20 install -d ${D}${base_sbindir}
21 install -d ${D}${sysconfdir}
22 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
23 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
24
25 if [ -e ${WORKDIR}/fw_env.config ]; then
26 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
27 else
28 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
29 fi
30}
31
32do_install_class-cross () {
33 install -d ${D}${bindir_cross}
34 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
35 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
36}
37
38SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
39uboot_fw_utils_cross() {
40 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
41}
42
43RPROVIDES_${PN} += "u-boot-fw-utils"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46BBCLASSEXTEND = "cross"