diff options
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r-- | recipes-bsp/rcw/rcw_git.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb new file mode 100644 index 00000000..2a03309c --- /dev/null +++ b/recipes-bsp/rcw/rcw_git.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Reset Configuration Word" | ||
2 | DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" | ||
5 | |||
6 | DEPENDS += "change-file-endianess-native" | ||
7 | |||
8 | inherit deploy | ||
9 | |||
10 | SRCBRANCH = "master" | ||
11 | SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2" | ||
12 | SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \ | ||
13 | file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/" | ||
19 | |||
20 | do_install () { | ||
21 | oe_runmake install | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOYDIR}/rcw | ||
26 | cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/ | ||
27 | } | ||
28 | addtask deploy after do_install | ||
29 | |||
30 | PACKAGES += "${PN}-image" | ||
31 | FILES_${PN}-image += "/boot" | ||
32 | |||
33 | ALLOW_EMPTY_${PN} = "1" | ||
34 | |||
35 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
36 | COMPATIBLE_MACHINE = "(ls102xa)" | ||