summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb')
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index 9c93d333..a992ab84 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -1,20 +1,21 @@
1SUMMARY = "PPFE Linux firmware" 1SUMMARY = "PPFE Linux firmware"
2LICENSE = "Freescale-Binary-EULA" 2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=f1c407c0fccab5cd0bf9b92565f6f19b" 3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=92723670f432558b9e2494ed177d2a85"
4
4 5
5INHIBIT_DEFAULT_DEPS = "1" 6INHIBIT_DEFAULT_DEPS = "1"
6 7
7inherit deploy 8inherit deploy
8 9
9SRC_URI = "git://github.com/qoriq-open-source/engine-pfe-bin.git;nobranch=1" 10SRC_URI = "git://github.com/NXP/qoriq-engine-pfe-bin.git;nobranch=1"
10SRCREV = "97cd13d3070d7199e62881bc495b332194b67edd" 11SRCREV = "848002fe4e0e3efb8d13a813e5c123bbc87aa95b"
11 12
12S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
13 14
14do_install () { 15do_install () {
15 install -d ${D}/lib/firmware 16 install -d ${D}/lib/firmware
16 install -d ${D}/boot/engine-pfe-bin 17 install -d ${D}/boot/engine-pfe-bin
17 install -m 644 ${S}/Freescale-Binary-EULA ${D}/lib/firmware 18 install -m 644 ${S}/NXP-Binary-EULA.txt ${D}/lib/firmware
18 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware 19 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware
19 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin 20 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin
20} 21}