diff options
Diffstat (limited to 'recipes-bsp/pkc-firmware/pkc-firmware_git.bb')
-rw-r--r-- | recipes-bsp/pkc-firmware/pkc-firmware_git.bb | 41 |
1 files changed, 0 insertions, 41 deletions
diff --git a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb deleted file mode 100644 index f5848ebe..00000000 --- a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | DESCRIPTION = "U-boot firmware for c293pcie support " | ||
2 | HOMEPAGE = "http://u-boot.sf.net" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | ||
5 | |||
6 | INHIBIT_DEFAULT_DEPS = "1" | ||
7 | DEPENDS = "virtual/${TARGET_PREFIX}gcc libgcc" | ||
8 | |||
9 | inherit deploy | ||
10 | |||
11 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
12 | |||
13 | SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1" | ||
14 | SRCREV = "209e0e6babdab43f38db84591307bedfd0bed542" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' | ||
19 | |||
20 | do_compile () { | ||
21 | unset LDFLAGS | ||
22 | unset CFLAGS | ||
23 | unset CPPFLAGS | ||
24 | oe_runmake C293QDS_36BIT_SDCARD | ||
25 | } | ||
26 | |||
27 | do_install(){ | ||
28 | install -d ${D}${sysconfdir}/crypto/ | ||
29 | install ${S}/u-boot.bin ${D}${sysconfdir}/crypto/pkc-firmware.bin | ||
30 | } | ||
31 | |||
32 | do_deploy(){ | ||
33 | install -d ${DEPLOYDIR}/pkc-firmware | ||
34 | install ${S}/u-boot.bin ${DEPLOYDIR}/pkc-firmware/pkc-firmware.bin | ||
35 | } | ||
36 | |||
37 | addtask deploy after do_install | ||
38 | |||
39 | FILES_{PN} += "/etc/crypto/pkc-firmware.bin" | ||
40 | COMPATIBLE_MACHINE = "(c293pcie)" | ||
41 | CLEANBROKEN = "1" | ||