summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mc-utils/mc-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/mc-utils/mc-utils_git.bb')
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
new file mode 100644
index 00000000..221c9e2d
--- /dev/null
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "The Management Complex (MC) is a key component of DPAA"
2SECTION = "mc-utils"
3LICENSE = "BSD"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987 \
6"
7
8DEPENDS += "dtc-native"
9
10inherit deploy
11
12SRC_URI = "git://github.com/qoriq-open-source/mc-utils.git;nobranch=1"
13SRCREV = "b79fe4b47364dfd2fe263f701ad6b818a75b036b"
14
15S = "${WORKDIR}/git"
16
17MC_CFG ?= ""
18MC_CFG_ls1088a = "ls1088a"
19MC_CFG_ls2088a = "ls2088a"
20
21do_install () {
22 oe_runmake -C config
23
24 install -d ${D}/boot/mc-utils/custom
25 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils
26 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
27}
28
29do_deploy () {
30 install -d ${DEPLOYDIR}/mc-utils/custom
31 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils
32 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
33
34}
35addtask deploy after do_install
36
37PACKAGES += "${PN}-image"
38FILES_${PN}-image += "/boot"
39COMPATIBLE_MACHINE = "(ls1088a|ls2088a)"