summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb')
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
new file mode 100644
index 00000000..bc40a1cf
--- /dev/null
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
@@ -0,0 +1,54 @@
1DESCRIPTION = 'Library for allocating and managing physically contiguous memory \
2 ("DMA memory" or "DMA buffers") on i.MX devices.'
3HOMEPAGE = "https://github.com/Freescale/libimxdmabuffer"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
6SECTION = "base"
7
8PV .= "+git${SRCPV}"
9
10SRCBRANCH ?= "master"
11SRCREV = "faf547cc2345bfbf95507ab7e86530f85289bb5b"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://run-ptest \
14 "
15
16
17S = "${WORKDIR}/git"
18
19inherit pkgconfig waf use-imx-headers ptest
20
21# dma-heap allocator is unavailable because it requires kernel 5.6 or newer.
22EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
23 --libdir=${libdir} \
24 --with-dma-heap-allocator=no \
25 ${PACKAGECONFIG_CONFARGS}"
26
27# If imxdpu is in use, the DPU is also used for implementing
28# libg2d. However, that implementation's g2d_alloc() function
29# is broken, so we cannot use it.
30LIBG2D_PACKAGECONFIG = "g2d"
31LIBG2D_PACKAGECONFIG_imxdpu = ""
32
33PACKAGECONFIG ?= " ion "
34PACKAGECONFIG_append_imxgpu2d = " ${LIBG2D_PACKAGECONFIG}"
35PACKAGECONFIG_append_imxipu = " ipu"
36PACKAGECONFIG_append_imxpxp = " pxp"
37PACKAGECONFIG_append_mx8m = " dwl"
38
39HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2"
40
41PACKAGECONFIG[dwl] = "--with-dwl-allocator=yes ${HANTRO_CONF},--with-dwl-allocator=no,imx-vpu-hantro"
42PACKAGECONFIG[ion] = "--with-ion-allocator=yes, --with-ion-allocator=no,"
43PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocator=no,"
44PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d"
45PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no,"
46
47# Using do_install_ptest_base instead of do_install_ptest, since
48# the default do_install_ptest_base is hardcoded to expect Makefiles.
49do_install_ptest_base() {
50 install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest
51 install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH}
52}
53
54COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"