summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb')
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb
new file mode 100644
index 00000000..a4252a7b
--- /dev/null
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.0.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = 'Library for allocating and managing physically contiguous memory \
2 ("DMA memory" or "DMA buffers") on i.MX devices.'
3HOMEPAGE = "https://github.com/Freescale/libimxdmabuffer"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
6SECTION = "base"
7
8PV = "1.0.0+git${SRCPV}"
9
10SRCBRANCH ?= "master"
11SRCREV = "db17cb57d1087cf590b28487c43cb5c47bf76fe7"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH}"
13
14S = "${WORKDIR}/git"
15
16inherit pkgconfig waf use-imx-headers ptest
17
18EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \
19 --libdir=${libdir} \
20 ${PACKAGECONFIG_CONFARGS}"
21
22PACKAGECONFIG ?= " "
23PACKAGECONFIG_append_imxgpu2d = " g2d"
24PACKAGECONFIG_append_imxipu = " ipu"
25PACKAGECONFIG_append_imxpxp = " pxp"
26PACKAGECONFIG_append_mx8m = " dwl ion"
27
28HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2"
29
30PACKAGECONFIG[dwl] = "--with-dwl-allocator=yes ${HANTRO_CONF},--with-dwl-allocator=no,imx-vpu-hantro"
31PACKAGECONFIG[ion] = "--with-ion-allocator=yes, --with-ion-allocator=no,"
32PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocator=no,"
33PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d"
34PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no,"
35
36do_install_ptest () {
37 install -d ${D}${PTEST_PATH}/tests
38 install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH}/tests
39}
40
41COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"