summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
new file mode 100644
index 00000000..ae96299a
--- /dev/null
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
@@ -0,0 +1,90 @@
1# Copyright 2020-2022 NXP
2
3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
6DEPENDS = "libdrm virtual/libg2d libtinyxml2"
7
8SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
9SRC_URI[md5sum] = "d0350ad40df96a84efc4802975f92c91"
10SRC_URI[sha256sum] = "5544aef41546906bc4999de1980e4706cf241c93732633efde57b018ac4863c3"
11
12inherit fsl-eula-unpack cmake systemd use-imx-headers
13
14# Build the sub-folder appshell
15OECMAKE_SOURCEPATH = "${S}/appshell"
16
17# Use make instead of ninja
18OECMAKE_GENERATOR = "Unix Makefiles"
19
20# Workaround for linking issues seen with gold linker
21LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
22
23SYSTEMD_SERVICE:${PN} = "imx8-isp.service"
24
25EXTRA_OECMAKE += " \
26 -DSDKTARGETSYSROOT=${STAGING_DIR_HOST} \
27 -DCMAKE_BUILD_TYPE=release \
28 -DISP_VERSION=ISP8000NANO_V1802 \
29 -DPLATFORM=ARM64 \
30 -DAPPMODE=V4L2 \
31 -DQTLESS=1 \
32 -DFULL_SRC_COMPILE=1 \
33 -DWITH_DRM=1 \
34 -DWITH_DWE=1 \
35 -DSERVER_LESS=1 \
36 -DSUBDEV_V4L2=1 \
37 -DENABLE_IRQ=1 \
38 -DPARTITION_BUILD=0 \
39 -D3A_SRC_BUILD=0 \
40 -DIMX_G2D=ON \
41 -Wno-dev \
42"
43
44do_install() {
45 install -d ${D}/${libdir}
46 install -d ${D}/${includedir}
47 install -d ${D}/opt/imx8-isp/bin
48 install -d ${D}/opt/imx8-isp/bin/dewarp_config
49
50 cp -r ${B}/generated/release/bin/*_test ${D}/opt/imx8-isp/bin
51 cp -r ${B}/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin
52 cp -r ${B}/generated/release/bin/*.xml ${D}/opt/imx8-isp/bin
53 cp -r ${B}/generated/release/bin/*.drv ${D}/opt/imx8-isp/bin
54 cp -r ${WORKDIR}/${BP}/dewarp/dewarp_config/ ${D}/opt/imx8-isp/bin
55 cp -r ${B}/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin
56 cp -r ${B}/generated/release/bin/vvext ${D}/opt/imx8-isp/bin
57 cp -r ${B}/generated/release/lib/*.so* ${D}/${libdir}
58 cp -r ${B}/generated/release/include/* ${D}/${includedir}
59
60 cp ${S}/imx/run.sh ${D}/opt/imx8-isp/bin
61 cp ${S}/imx/start_isp.sh ${D}/opt/imx8-isp/bin
62
63 chmod +x ${D}/opt/imx8-isp/bin/run.sh
64 chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh
65
66 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
67 install -d ${D}${systemd_system_unitdir}
68 install -m 0644 ${S}/imx/imx8-isp.service ${D}${systemd_system_unitdir}
69 fi
70}
71
72# The build contains a mix of versioned and unversioned libraries, so
73# the default packaging configuration needs some modification so that
74# unversioned .so libraries go to the main package and versioned .so
75# symlinks go to -dev.
76FILES_SOLIBSDEV = ""
77FILES_SOLIBS_VERSIONED = " \
78 ${libdir}/libar1335.so \
79 ${libdir}/libjsoncpp.so \
80 ${libdir}/libos08a20.so \
81 ${libdir}/libov2775.so \
82"
83FILES:${PN} += "/opt ${libdir}/lib*${SOLIBSDEV}"
84FILES:${PN}-dev += "${FILES_SOLIBS_VERSIONED}"
85
86INSANE_SKIP:${PN} = "rpaths"
87
88RDEPENDS:${PN} = "libdrm"
89
90COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"