summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb
new file mode 100644
index 00000000..9f975511
--- /dev/null
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb
@@ -0,0 +1,88 @@
1# Copyright 2020-2021 NXP
2
3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2"
7
8SRC_URI = " \
9 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
10 file://0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch \
11 file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \
12"
13
14SRC_URI[md5sum] = "e9e0943b9f4923c767d07901e550c41c"
15SRC_URI[sha256sum] = "13274c0fd442da4b3b9900a7568c59872ffa6408f5699d35eebc6760a8e51297"
16
17inherit fsl-eula-unpack cmake systemd use-imx-headers
18
19# Build the sub-folder appshell
20OECMAKE_SOURCEPATH = "${S}/appshell"
21
22# Use make instead of ninja
23OECMAKE_GENERATOR = "Unix Makefiles"
24
25SYSTEMD_SERVICE:${PN} = "imx8-isp.service"
26
27EXTRA_OECMAKE += " \
28 -DCMAKE_BUILD_TYPE=release \
29 -DISP_VERSION=ISP8000NANO_V1802 \
30 -DPLATFORM=ARM64 \
31 -DAPPMODE=V4L2 \
32 -DQTLESS=1 \
33 -DFULL_SRC_COMPILE=1 \
34 -DWITH_DRM=1 \
35 -DWITH_DWE=1 \
36 -DSERVER_LESS=1 \
37 -DSUBDEV_V4L2=1 \
38 -DENABLE_IRQ=1 \
39 -DPARTITION_BUILD=0 \
40 -D3A_SRC_BUILD=0 \
41 -DIMX_G2D=ON \
42 -Wno-dev \
43"
44
45do_configure:prepend() {
46 export SDKTARGETSYSROOT=${STAGING_DIR_HOST}
47}
48
49do_install() {
50 install -d ${D}/${libdir}
51 install -d ${D}/${includedir}
52 install -d ${D}/opt/imx8-isp/bin
53
54 cp -r ${WORKDIR}/build/generated/release/bin/*_test ${D}/opt/imx8-isp/bin
55 cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin
56 cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin
57 cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin
58 cp -r ${WORKDIR}/${BP}/dewarp/dewarp_config/ ${D}/opt/imx8-isp/bin
59 cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir}
60 cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir}
61
62 cp ${WORKDIR}/${BP}/imx/run.sh ${D}/opt/imx8-isp/bin
63 cp ${WORKDIR}/${BP}/imx/start_isp.sh ${D}/opt/imx8-isp/bin
64
65 chmod +x ${D}/opt/imx8-isp/bin/run.sh
66 chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh
67
68 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
69 install -d ${D}${systemd_system_unitdir}
70 install -m 0644 ${WORKDIR}/${BP}/imx/imx8-isp.service ${D}${systemd_system_unitdir}
71 fi
72}
73
74# The build contains a mix of versioned and unversioned libraries, so
75# the default packaging configuration needs some modifications
76FILES_SOLIBSDEV = ""
77FILES:${PN} += "/opt ${libdir}/lib*${SOLIBSDEV}"
78FILES:${PN}-dev += " \
79 ${libdir}/libjsoncpp.so \
80 ${libdir}/libos08a20.so \
81 ${libdir}/libov2775.so \
82"
83
84INSANE_SKIP:${PN} = "rpaths"
85
86RDEPENDS:${PN} = "libdrm libpython3"
87
88COMPATIBLE_MACHINE = "(mx8mp)"