summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
new file mode 100644
index 00000000..35adecf8
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
11 file://0001-buildsystem-don-t-ignore-externally-set-cflags.patch \
12"
13SRC_URI[md5sum] = "cfa0e92da0eca9cf622c4d7abc618cef"
14SRC_URI[sha256sum] = "7e9bcdbd067ce66a1247373cbf088945346feb0027deb61af541ebc1256277c3"
15
16inherit fsl-eula-unpack use-imx-headers
17
18PARALLEL_MAKE="-j 1"
19
20PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
21PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
22PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
23
24EXTRA_OEMAKE = " \
25 CROSS_COMPILE="${HOST_PREFIX}" \
26 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
27 PLATFORM="${PLATFORM}" \
28"
29
30do_install () {
31 oe_runmake install DEST_DIR="${D}"
32}
33
34FILES:${PN} += "/unit_tests"
35
36RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
37
38PACKAGE_ARCH = "${MACHINE_SOCARCH}"
39COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"