summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
new file mode 100644
index 00000000..473d747c
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "cfa0e92da0eca9cf622c4d7abc618cef"
11SRC_URI[sha256sum] = "7e9bcdbd067ce66a1247373cbf088945346feb0027deb61af541ebc1256277c3"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
18PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
19PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"