summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb
new file mode 100644
index 00000000..1e347ca8
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.19.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=983e4c77621568488dd902b27e0c2143"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
11 file://0001-decoder_sw-resolve-compilation-error-with-fcommon.patch \
12"
13SRC_URI[md5sum] = "05a2c37fddcabdadd5fa37d3a38914c6"
14SRC_URI[sha256sum] = "261cab83954bd66e95b1650a737cb36261a2098597d904e517da638097ed4fd2"
15
16inherit fsl-eula-unpack use-imx-headers
17
18PARALLEL_MAKE="-j 1"
19
20PLATFORM_mx8mm = "IMX8MM"
21PLATFORM_mx8mq = "IMX8MQ"
22PLATFORM_mx8mp = "IMX8MP"
23
24do_compile () {
25 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
26 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
27 PLATFORM="${PLATFORM}" all
28}
29
30do_install () {
31 oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
32}
33
34FILES_${PN} += "/unit_tests"
35
36COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"