summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch
new file mode 100644
index 00000000..861230bb
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch
@@ -0,0 +1,49 @@
1From aba22ec2e285cf7557a5049fa6181e82e7f1a489 Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Mon, 21 Nov 2022 12:04:09 +0000
4Subject: [PATCH] buildsystem: don't ignore externally set cflags
5
6Upstream-Status: pending
7Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
8---
9 decoder_sw/software/linux/h264high/Makefile | 4 ++--
10 decoder_sw/software/linux/vp6/Makefile | 4 ++--
11 2 files changed, 4 insertions(+), 4 deletions(-)
12
13diff --git a/decoder_sw/software/linux/h264high/Makefile b/decoder_sw/software/linux/h264high/Makefile
14index 556ff71..7bdd99d 100755
15--- a/decoder_sw/software/linux/h264high/Makefile
16+++ b/decoder_sw/software/linux/h264high/Makefile
17@@ -50,10 +50,10 @@ CLEAR_HDRINFO_IN_SEEK = n
18 DEBUG = y
19 # Add your debugging flag (or not) to CFLAGS
20 ifeq ($(DEBUG),y)
21- CFLAGS = $(M32) -g -O0
22+ CFLAGS += $(M32) -g -O0
23 DEBFLAGS = -DDEBUG -D_ASSERT_USED -D_RANGE_CHECK -D_ERROR_PRINT
24 else
25- CFLAGS = $(M32) -O3
26+ CFLAGS += $(M32) -O3
27 DEBFLAGS = -DNDEBUG
28 endif
29
30diff --git a/decoder_sw/software/linux/vp6/Makefile b/decoder_sw/software/linux/vp6/Makefile
31index b6e6914..b933d46 100755
32--- a/decoder_sw/software/linux/vp6/Makefile
33+++ b/decoder_sw/software/linux/vp6/Makefile
34@@ -50,10 +50,10 @@ DEBUG = y
35
36 # Add your debugging flag (or not) to CFLAGS
37 ifeq ($(DEBUG),y)
38- CFLAGS = -g -O0
39+ CFLAGS += -g -O0
40 DEBFLAGS = -DDEBUG -D_ASSERT_USED -D_ERROR_PRINT
41 else
42- CFLAGS = -O3
43+ CFLAGS += -O3
44 DEBFLAGS = -DNDEBUG
45 endif
46
47--
482.35.3
49