diff options
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb new file mode 100644 index 00000000..58a140b4 --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | # Copyright (C) 2019-2021 NXP | ||
2 | |||
3 | DESCRIPTION = "i.MX VC8000E Encoder library" | ||
4 | LICENSE = "Proprietary" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b" | ||
6 | |||
7 | inherit fsl-eula-unpack | ||
8 | |||
9 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | ||
10 | |||
11 | S = "${WORKDIR}/${BPN}-${PV}" | ||
12 | |||
13 | SRC_URI[md5sum] = "b5270450ba2da5b7468b67ae8c0bcdca" | ||
14 | SRC_URI[sha256sum] = "d5efae484c4271c098286d007590d6bf40c272d4f35702ff65625f2362715ab3" | ||
15 | |||
16 | # SCR is the location and name of the Software Content Register file | ||
17 | # relative to ${D}${D_SUBDIR}. | ||
18 | SCR = "SCR.txt" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}${D_SUBDIR} | ||
22 | cp -r ${S}/* ${D}${D_SUBDIR} | ||
23 | if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then | ||
24 | mv ${D}/usr/lib ${D}${libdir} | ||
25 | fi | ||
26 | rm ${D}${D_SUBDIR}/COPYING | ||
27 | if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then | ||
28 | bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\"" | ||
29 | fi | ||
30 | rm ${D}${D_SUBDIR}/${SCR} | ||
31 | } | ||
32 | |||
33 | FILES_${PN} = "/" | ||
34 | |||
35 | COMPATIBLE_MACHINE = "(mx8mp)" | ||