summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test/imx-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-test/imx-test_git.bb')
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index 729e2670..fae459ca 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
10 10
11DEPENDS = "linux-imx-headers alsa-lib libdrm" 11DEPENDS = "alsa-lib libdrm"
12DEPENDS_append_mx6 = " imx-lib" 12DEPENDS_append_mx6 = " imx-lib"
13DEPENDS_append_mx7 = " imx-lib" 13DEPENDS_append_mx7 = " imx-lib"
14 14
@@ -24,7 +24,7 @@ SRC_URI = " \
24SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be" 24SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be"
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit module-base 27inherit module-base use-imx-headers
28 28
29INHIBIT_PACKAGE_STRIP = "1" 29INHIBIT_PACKAGE_STRIP = "1"
30INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 30INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
@@ -55,9 +55,9 @@ do_compile() {
55 CFLAGS="${TOOLCHAIN_OPTIONS}" 55 CFLAGS="${TOOLCHAIN_OPTIONS}"
56 oe_runmake V=1 VERBOSE='' \ 56 oe_runmake V=1 VERBOSE='' \
57 CROSS_COMPILE=${TARGET_PREFIX} \ 57 CROSS_COMPILE=${TARGET_PREFIX} \
58 INC="-I${STAGING_INCDIR} \ 58 INC="-I${S}/include \
59 -I${S}/include \ 59 -I${STAGING_INCDIR} \
60 -I${STAGING_INCDIR}/imx" \ 60 -I${STAGING_INCDIR_IMX}" \
61 CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ 61 CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \
62 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ 62 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
63 LINUXPATH=${STAGING_KERNEL_DIR} \ 63 LINUXPATH=${STAGING_KERNEL_DIR} \
@@ -82,5 +82,4 @@ RDEPENDS_${PN} = "bash"
82 82
83FILES_${PN}-dbg += "/unit_tests/.debug" 83FILES_${PN}-dbg += "/unit_tests/.debug"
84 84
85PACKAGE_ARCH = "${MACHINE_SOCARCH}"
86COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 85COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"