diff options
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_0.2.bb | 8 |
1 files changed, 0 insertions, 8 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb index bd57dd03..13e161ac 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |||
@@ -41,10 +41,6 @@ ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin" | |||
41 | ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" | 41 | ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" |
42 | ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}" | 42 | ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}" |
43 | 43 | ||
44 | DCD_NAME ?= "imx8qm_dcd.cfg.tmp" | ||
45 | DCD_NAME_mx8qm = "imx8qm_dcd.cfg.tmp" | ||
46 | DCD_NAME_mx8qxp = "imx8qx_dcd.cfg.tmp" | ||
47 | |||
48 | UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}" | 44 | UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}" |
49 | BOOT_CONFIG_MACHINE = "${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG}.bin" | 45 | BOOT_CONFIG_MACHINE = "${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG}.bin" |
50 | 46 | ||
@@ -141,15 +137,11 @@ deploy_mx8m() { | |||
141 | } | 137 | } |
142 | deploy_mx8() { | 138 | deploy_mx8() { |
143 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | 139 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} |
144 | install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
145 | install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} | 140 | install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} |
146 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 141 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
147 | } | 142 | } |
148 | deploy_mx8x() { | 143 | deploy_mx8x() { |
149 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | 144 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} |
150 | if [ "${MACHINE}" = "imx8qxpa0mek" ]; then | ||
151 | install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
152 | fi | ||
153 | install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} | 145 | install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} |
154 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 146 | install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
155 | } | 147 | } |